Jump to content

Recommended Posts

Hi im having a problem.
Im trying making a Digital Asset.

 

 

-First a object is proportional normalized to the grid unit of 1.

 

-Later on no matter what effect / scale, it sets everything back to the normal postition.

 

This all go's fine but after normalized at the beginning its off in the Y axis for 0.008 units below the grid.

Ofcourse i can move it up but i want to know what im doing wrong and i cant figure it out.

(and keep it procedural)

 

here is mij transform code(X,Y,Z):

1/if($SIZEZ > if($SIZEX > $SIZEY, $SIZEX,$SIZEY),$SIZEZ, if($SIZEX > $SIZEY, $SIZEX,$SIZEY))

 

 

(and there is my sample file with notes)

 

i would love to hear what the reason is.

its in the first transform of the node tree

THNX ALOT!!!!

Normalize_And_Back.hip

Share this post


Link to post
Share on other sites

in ty use -$YMIN instead

and set your py back to 0

 

move negative the lowest point of the object will always put it on the ground.

  • Like 2

Share this post


Link to post
Share on other sites

thnx...

Yes i knew that but i was wondering why after normalized its off 0,008 units based on your geometry-IN

It should have a max bound of 1 which means i have to travel it 0.5 on Y-axis

Share this post


Link to post
Share on other sites

I think it's because you are moving the object by the centroid. Resetting Translate to 0 works.

 

Also you can use max(max(x,y), z) instead of if statements.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×