Jump to content
Sign in to follow this  
DocWhite

Rendering Motion Blur (random trails, why?)

Recommended Posts

Hello guys I need some help. I am trying to get a nice tail for the marbles in this DOP simulation. Under the Geometry node "Geometry Velocity Blur" us checked and in the Mantra node I am enabling to render Motion Blur. Is there a way to re-calculate the direction of the blur based on the particle's velocity? Cannot figure out why the direction of the blur sometimes is even perpendicular to the velocity vector!

 
Here is the video: https://vimeo.com/112666106

post-10566-0-88821700-1416801525_thumb.p

Any suggestion? Thanks a lot guys!

post-10566-0-88821700-1416801525_thumb.p

Share this post


Link to post
Share on other sites

I think it is because mantra uses velocity from next frame. Try to set Shutter offset to 0.

Share this post


Link to post
Share on other sites

Yes, it's because of Shutter Offset 1 which blurs current to next frame also called leading motion blur. -1 is trailing blur and 0 is current frame blur.

Share this post


Link to post
Share on other sites

I think it is because mantra uses velocity from next frame. Try to set Shutter offset to 0.

 

 

Yes, it's because of Shutter Offset 1 which blurs current to next frame also called leading motion blur. -1 is trailing blur and 0 is current frame blur.

 

I changed to option to -1 and 0 and I still get weird directions. I think it has to do with the way the velocity is computed... Thanks for your reply guys.

Share this post


Link to post
Share on other sites

OK! Now I am getting improvements. What I did was reading the documentation and it says:
 

Geo time samples: The number of deformation blur motion samples. Each object (unless the parameter exists on the object) will have this many copies of the geometry included in the IFD. When an object is deforming it is necessary to increase this parameter to a value of 2 to see motion blurred geometry. Any number of segments may be specified, though a value of 2 is often adequate unless significant nonlinear motion occurs within the shutter time for a frame. This option has no effect on objects which use velocity blur, since velocity blur is linear by nature. 

So I unchecked "Geometry Velocity Blur" under the Geometry node (Geo Node > Render > Sampling) and increased the Geo Time Samples to 5. Now I am getting better results, the problem is that I wanted to get larger motion trails. Shutter offset is at -1. To have larger trails you have to go to the Camera node and set the Shutter Time to a larger number. It worked for me. The Shutter Offset was one of these things. Thanks guys.

Share this post


Link to post
Share on other sites

sometimes people run into weird motion blur issues because they alter the point count (say by deleting via frustrum) - this could break motion blur or introduce artifacts.

 

if you are altering point counts, you need to be using a trail sop to generate velocities BEFORE any delete/fuse operations to get stable results.

 

easy to forget this in the heat of the moment :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×