Jump to content
ninjismo

HtoA not dumping .ass files for volumes

Recommended Posts

Hey,

 

I'm having some trouble generating .ass files for volumes in Houdini so they can be lit by lighters in Maya using Arnold. 

I'm using Houdini FX 14.0.201.13 with HtoA 1.3.1 (which the website says is the correct version of HtoA for my version of Houdini). 

The steps that I used to get Arnold to work with Houdini is that I manually installed the plugin and had my houdini.env point to the plugin location, and the console seems to have all the arnold plugins loaded at startup.

 

I created a shelf tool pyroFX explosion, converted it to VDB using "density" and "heat" as the groups. I then called those fields back using an Arnold Volume node at scene level, with the grids as density and heat. It displays the volume in the viewport, and renders out the scene if I put down some arnold lights and render it with an Arnold ROP in Houdini itself. 

 

In the Archive tab of the Arnold ROP, I set the location to where I want to have the .ass files dumped and uncheck "export lights" and "export cameras". When I hit the render button I get this message in the console - 

 

00:00:00  1127MB WARNING | [htoa.session] generating shaders...

00:00:00  1127MB WARNING | [htoa.session] shader generation done.

 

HtoA ends up generating a .ass file that is only 2KB in size, always. When I take a simple sphere and apply a shader to it and dump out the .ass file, it works, but not with volumes. 

 

Anyone knows why this isn't working for me? 

 

Share this post


Link to post
Share on other sites

You need to export your volume to VDBs to disk. Then set path to VDBs in Arnold Volume node.

After that a path to volumes is contained in ASS file. And if you are moving ASSs to another machine remember that you need to move VDBs as well.

Share this post


Link to post
Share on other sites

Another quick question based on aruns :

How to visualise htoa volumes in maya viewport imported as standins (.ass)?
As of now I m able to render volume using arnold renderer

Only I can see is bounding box in the viewport & not volumes.

Tried changing display & viewport settings but nothings working.

 

Doe anyone knows how to fix it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×