Jump to content
Sign in to follow this  
houdini1987

Depth pass comp issue

Recommended Posts

Hi,

I am facing a weird issue when i am trying to comp my z depth from file rendered from Houdini in Nuke. I am getting weird red edges even if its not in focus that blurs it. Also blur is so weird. I know for sure its not the problem of Nuke because z defocus node is working well with another exr I downloaded over internet. I don't know what I am missing.

Any pointer will be very helpful.

Thanks

post-10148-0-43939700-1442255106_thumb.p

post-10148-0-40356200-1442255111_thumb.p

post-10148-0-75327400-1442255171_thumb.p

Share this post


Link to post
Share on other sites

try 'minmax idcover' in the Pixel Filter

Thanks Marty,

It worked really well. Can I ask why min max idcover thing worked even its not present in drop down of pixel filter. Usually I use Gaussian 2x2 but that didn't even work?

post-10148-0-39429800-1442299583_thumb.p

post-10148-0-24730900-1442299590_thumb.p

Share this post


Link to post
Share on other sites
Guest tar

It's the bottom option - Object With Most Pixel Coverage (no filtering)

 

Gaussian won't work as Z-depth is based on float values, and where you have smooth anti-aliased edges it is interrupted as a different depth.

 

The very best thing to do is probably render with 'Sub-Pixel Output' checked - then do you defocus on it, then reformat it down in Nuke.

 

Of course then a another cool method is use Deep output and  Bokeh from http://peregrinelabs.com/bokeh/ :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×