Jump to content
Sign in to follow this  
lazza79

Volume "gap" [SOLVED]

Recommended Posts

Hi guys,

 

sorry to annoy you but I am just entered in the "world" of VFX and CG and I need your help :D

 

I am trying to create a shot of a boat moving.

I have created a collision geometry, a proxy volume, and run the simulation (particle separation is always 0.03).

 

Once I converted the particles to volume and then to polygon soup, I noticed that the water moved by the bow is wrong: there is a small "gap" between the bow and the water, as if something is between them.

 

I am posting 2 screenshot of the particle simulation and the conversion to volume.

 

Thank you for your help

 

post-14285-0-66932500-1443174158_thumb.p

 

post-14285-0-09704100-1443174151_thumb.p

 

I don't know if you can see it but the lower part of the volume is correctly attached to the boat, but then the distance increases...

post-14285-0-99720300-1443174402_thumb.p

 

Cheers,

Lazza 79

Edited by lazza79

Share this post


Link to post
Share on other sites

FLIP fluids collide against volume sdf collider volumes. Not the polygons/surfaces.

 

The Collision volume constructed from the boat hull in the Static Object DOP is re-constructed in the FLIP Solver. By default this collision volume is at the same resolution of the FLIP fluid. At coarse FLIP resolutions, you get a coarse collision surface.

 

You can enable Collision Separation on the flip Object DOP and set it to a smaller separation value than the FLIP simulation.

 

When working with a collider in FLIP, it is always a good idea to verify the collider resolution by turning off the display on the Static Object DOP then on the Flip Object DOP, turn on the collision volume in the Guides tab. You also may have to change the viewport to "Hide Other Objects". Once it is all good, turn the collision volume display off and turn back on the display of the surface. Looks better to those looking over your shoulder.

 

----

 

Houdini14 added the VDB collision workflow for FLIP fluids. You get this set up when you bring in your colliders with the Deforming Object Tool on the RBD shelf. The VDB collider will have a volume separation value associated with it. Set this value to a low enough value to get a reasonable VDB SDF collider that represents your polygonal geometry. Then you can use this value on the FLIP Object DOP's collision separation value. Not necessary but will make things more efficient.

Share this post


Link to post
Share on other sites

Hi "Old School" and thank you for the reply.

 

I am not sure I understood your reply

 



FLIP fluids collide against volume sdf collider volumes. Not the polygons/surfaces.

I use the geometry model converted to a VDB volume as a "volume proxy" in the simulation.

 

post-14285-0-34837800-1443189729_thumb.p

 

 

"You can enable Collision Separation on the flip Object DOP and set it to a smaller separation value than the FLIP simulation."

 

I just noticed that the voxel size of my model is 0.04 and the particle separation in my simulation is 0.03, is this that you are referring to in the above quote? May be the problem?

 

 

I am attaching my file, could you be so kind to put some notes in it where these modifications should be done?

(FYI, the frame shown in my screenshots is 27)

As I stated I am a noob and I have not full confidence on the terminology yet...

 

Thanks a lot!

Lazza79

 

yacht_v02a.hip

boatExport.zip

Edited by lazza79

Share this post


Link to post
Share on other sites

Thank-you for posting the file. It is the only way to resolve these things in a couple posts.

 

I think your issue is found is the very first thing I always do when debugging collisions with flip:

"When working with a collider in FLIP, it is always a good idea to verify the collider resolution by turning off the display on the Static Object DOP then on the Flip Object DOP, turn on the collision volume in the Guides tab."

But I always compare the two as I toggle on the collision volume and look/inspect, then turn and on the actual geometry to see what is being dropped or mis-represented in the volume.

 

post-371-0-05826800-1443270387_thumb.jpg

 

So did that and immediately found a discrepancy between the geometry that the Boat_Motion Static Object DOP. Quite an offset. I believe this is the offset that you are observing in DOPs. You are comparing the polygon geometry fed in by the Boat object but using the collision VDB grids from the Boat_Transformation_Boat object.

 

The issue is that the VDB grids are being supplied by the Boat object but the render geometry is being supplied by the object Boat_Transformation_Boat which is using expressions fed by two points to locate the boat.

 

Make up your mind what you want and then use the same object to supply both the polygon geometry (that you most likely will intend to render or a proxy of this) and the collision geometry in to the Boat_Motion Static Object DOP.

 

If I understand your file, you may want to replicate (copy/paste) the network constructing the collision VDB grids from the Boat object in to the Boat_Transformation_Boat object and then use that to feed in to the Static Object DOP.

 

 

Hope that helps.

Edited by old school

Share this post


Link to post
Share on other sites

THANK YOU VERY MUCH, OLD SCHOOL!!!

 

I did the most stupid of the errors: since both the volume nulls from "BOAT" and "BOAT_MOTION" had the same name, I confused them!

I should have checked better, before asking for help! Now should be ok!

 

post-14285-0-69072200-1443434135_thumb.p

 

Anyway, it's all experience, thanks a lot!

 

If you pass from London, contact me and I'll buy you a beer!

 

See you soon mate!

 

Best regards,

Andrea

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×