Jump to content
Mzigaib

Another mantra network rendering issue thread

Recommended Posts

Is anyone having problems to use mantra network rendering ("mantra -H host1,host2") on H15?

 

I am using linux and I already did everything that I've found on the forums and in the wiki and nothing works I always get the error:

 

-When I use ip address - "Unable to initiate communications for 30 seconds" - take 30 sec

-When I use the host name - "Unable to contact remote hserver" - instantaneous message

 

 

I already did:

 

-Checked the if the same hserver version is running;

-Opened the 1714 and 1715 ports;

-Disabled firewall;

-Edit the hserver.opt setting the "readIpMask and writeIpMask" to +.+.*.* and *.*.*.*, also the "Read and Write" to the same;

-Set the license to central and also to local;

-Already checked to see if I can "ping" the ip and the host names.

 

I can't think anything else to try, please can anyone give me any tips? Or maybe it is a bug?

 

Thanks.

Edited by Mzigaib

Share this post


Link to post
Share on other sites

Michel are you using

1 - directly the command line to throw your renders ?

2 - Or do you use Hqueue ?

 

If it's case 1 i would try to setup a proper Hqueue farm

http://www.sidefx.com/docs/hqueue15.0/help/faqs#how-do-i-add-a-linux-client-machine-to-the-farm

 

Because it will give you a lot of log files / error files that will help you isolate where the problem come from.

I've just go throw some big PITA to setup mine on Windows 10. and googling the logs file help a lot.

 

In my case it was an access permission on client that was the problem even by :

- setting 777

- disabling the firewall

 

I had to start the client manually in admin mode to allow the server to see my machine correctly.

Edited by sebkaine

Share this post


Link to post
Share on other sites

Thank you very much for the feedback.

 

I am not using hqueue because I already have a render manager for the farm and I am not trying to use the farm to render individual frames I want to send individual buckets from a single frame to other machines interactively, that's why I am trying to use "mantra -H".

 

So I tried to solutions listed here http://odforce.net/wiki/doku.php?id=mantraremoterendering and also in the forums and nothing worked so far.

 

Maybe a Houdini version bug? who knows?

 

Anyone? :D

Edited by Mzigaib

Share this post


Link to post
Share on other sites

In case anyone wants to know the I solved the problem editing the "hosts" file in linux writing the ip's of the machines that are going to be the "slaves", this way hserver can find those machines in the network.

You can also make it work if you set your DNS server to find those machines but I don't how to do it the guys here in the IT department set this up for me, anyway it's awesome to have more than one machine rendering your frame!

 

I hope that helps someone.

 

Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×