Jump to content
Sign in to follow this  
Sourabh

Cracks are visible in render before it happen

Recommended Posts

Hey guys 

I have done inner and edge displacement on my fracture pieces ,it looks fine but while rendering cracks are visible before it happen  

see in the below image 

 

Note: (I have done the fracture pieces and displacement manually not with voronoi fracture node) 

 

Thank you 

post-16147-0-12603500-1460643754_thumb.j

Edited by Sourabh

Share this post


Link to post
Share on other sites

How have you done the fracturing? Can you supply a hip file? I think most of your problems could be solved with  some manipulation of your normals. 

Share this post


Link to post
Share on other sites

Hi.

 

Here, the problem don´t seem to happen.

post-7461-0-92972300-1460656629_thumb.jp

Share this post


Link to post
Share on other sites

It looks like the problem comes only when you add displacement. Have you tried adding the displacement only to the pieces that have moved? You can compare the point position to a rest position and use that to dial in the displacement amount in the shader. That way the cracks on the flat pieces shouldn't show. I don't have time to play around with it right now, but can take a look later. 

 

Cheers, 

 

WD

Share this post


Link to post
Share on other sites

Hi Guilherme Casagrandi 

 

You render this without displacement material .Try render with material i made (material name displacement_2 for inner displacement and displacement _3 for outer displacement).

Share this post


Link to post
Share on other sites

Hi Joe Long

I tried what you told me..but not working properly. Perhaps i did it wrong way. I wonder if you could tell me how to do that or show me in my given file above.

Thank You

Share this post


Link to post
Share on other sites

Hi Sourabh, 

 

I just had a little play around with your scene. I got rid of the unwanted displacement by dialling in the amount based in difference between P and rest. You seemed to be using rest in your shader but there was no rest attribute on the geo, so I added that. There was also a fuse which was causing the point count to change which was messing with rest position, so I disabled that. This might require a workaround. The noise I added is not the same as yours, you will need to tweak that to get it to match. I also only applied it to one of your shaders, you can do the other! ;D

 

I hope this helps. 

 

Cheers, 

 

WD

 

 

displacement_smoothTop.hipnc

  • Like 1

Share this post


Link to post
Share on other sites

Hi Joe Long,

 

Thanks you so much. This is exactly what i want to do. I was stuck in this. 

 

Thank you :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×