Jump to content
Sign in to follow this  
notintricate

Deep exr samples loss

Recommended Posts

Hey,

I was trying to render into deep exr and faced such issue:

I have simple shader with opacity falling off to object's edges. Unfortunately my deep outputs suffer on low pixel sampling rates loosing samples, however simple color exr does not.

So I wonder why deep samples are lost and how to make them to be present on low sampling rates? Appreciate your help!

 

*Dcm compression is set to 0

Here are simple examples of what I get:

pixel samples 3x3

 

3.png

pixel samples 7x7

7.png

shader

 

shader.png

Edited by notintricate

Share this post


Link to post
Share on other sites
8 hours ago, Jason said:

Thanks for reply, Jason. I'm using 416 build, and according to journal it seems that there weren't any fixes related to deep since that build. (However I will try the latest daily build to be sure)

Should I post this one to the SideFx forum? I don't know if it's expected behaviour or some kind of a bug to be reported.

Share this post


Link to post
Share on other sites

I submitted this as a bug to SESI and was suggested to use a workaround: turn off stochastic transparency to fix the problem with lost deep samples.

Here's SESI's reply:

Quote

There is currently a limitation with stochastic transparency when writing 'Ce' with DCM outputs. We currently skip the sample compositing step, which results in the holes you are seeing.

We are going to promote this question to a bug and address a fix for this, if possible.
 

 

Edited by notintricate
update

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×