Jump to content
charliejh

Houdini Billowy Smoke Artifacts Square

Recommended Posts

Hi,

I'm trying to create a moving dust cloud.

When I render it I get this result no matter how I tweak things in the pyrosolver. I'd like it to be less fluffy, round and circular and more wispy and aggressive (think MadMax).

 

Any help appreciated, Thankyou

 

 

hdni.jpg

Desert_v03.hipnc

Share this post


Link to post
Share on other sites

I'm unable to render at the moment, but the root cause is probably that your pyro_import object has no material.

Share this post


Link to post
Share on other sites

It's not the material, you should try with reasonable scale, at the moment most of the properties are quite high because of that. Try something like 100 times smaller scale. Most of the simulations doesn't work well that with that large scale.

Share this post


Link to post
Share on other sites

I dont know if the blocks are from a low resolution or your dist being 500 and block size 360:lol:.

Bring that wayyy down my friend to around the rest of the parms.

you can get a wispier look by decreasing density scale on the shader. To get a round plume you need to let the smoke unfold naturally. Decreasing your buoyancy lift and direction. Give it a small value to nudge it in direction then let it ride. The plumes will show themselves 48+ frames in.

Im not sure how new you are but you should iterate at a higher resolution then that by decreasing division size on smoke object.

Share this post


Link to post
Share on other sites

If after making the above mentioned adjustments you are still getting some blockiness artifacts you can either add a gas disturbance microsolver or you can increase the disturbance on the pyrosilver itself.  Additionally, increased turbulence can also be helpful.

 

Share this post


Link to post
Share on other sites

Thanks I'll give all these suggestions a go today. It's at such a large scale because of the maya scene i've been given.

A car is driving along a straight road with the camera leading, everythings to scale I think, which is why the scene is hundreds and hundreds of metres.

Share this post


Link to post
Share on other sites

If your simulating at 100 meters you wont be able to get a good resolution without a farm..

you should scale your whole scene down by .1

Share this post


Link to post
Share on other sites
17 minutes ago, Yon Anadeyo said:

If your simulating at 100 meters you wont be able to get a good resolution without a farm..

you should scale your whole scene down by .1

Do you know how to do that if there is an Alembic camera in the scene? I can uniform scale down the geometry to 0.1 but I cant scale down the camera (its movements stay the same and thus move off of the geometry).

Share this post


Link to post
Share on other sites

At the very bottom of your alembic archive there is a xform node as shown in attached screenshot

Or you can connect a null to it on object level and scale that but can cause problems when rendering.

I fixed your simulation but the camera and geo was not attached with the hip you provided.

Your scene needed to be scaled by 0.001, you will see in the hip a null called Scene_Down. You can multiply what you want to scale down by the parameter in it - like you can see on the Tube object.

High resolution pyro is usually 0.025, anything above .1 is considered low. Your division size was 175.

Anyway, scale your geo and camera by that parm in the null and everything should fit

Capture 2.JPG

Capture.JPG

Desert_v04.hipnc

Share this post


Link to post
Share on other sites

Mate I've just had a quick look and it looks as though you've hit the nail on the head. I'm gonna get back to it in a few hours so I'll dig a little deeper. Thankyou so much for the great response!

Also, The reason for the massive division size was when I took the tube and turned it into billowy smoke, it just made the division size that massive number by default, so wasnt too sure whether to change it or not. Thanks again!
 

Share this post


Link to post
Share on other sites

no problem let me know if anything else comes up

Share this post


Link to post
Share on other sites
1 hour ago, Yon Anadeyo said:

no problem let me know if anything else comes up

Okay so i've imported my geo and my camera, how do I get the parameter from the tube object over to the geo and camera? Also, as soon as i copy the parameter, will the geo and camera automatically scale down since the null is already set to 0.001?

Edited by charliejh

Share this post


Link to post
Share on other sites

You can scale your geo on object level just enter 0.001 into the three scale parms

and the same for the xform node at the bottom of your alembic archive.

If that xform node doesn't work use a null

Capture 2.JPG

Capture 3.JPG

Capture.JPG

Share this post


Link to post
Share on other sites

Okay heres my latest scene file with the camera and geo. 

I've got all the sizing sorted and changed to 0.001

Next problem is the pyro itself. When I select the tube and convert it to billowy smoke, it changes the sizing back to strange amounts again in the parameters (such as 0.62 division, 1.76 disturbance etc) . I think its to do with the length of the tube.

Is a tube even the right way to go about this? I just need the dust to go the length that the camera travels so it gently flows over the road as the camera moves. 

Thanks

Desert_Geo_OBJ.obj

Camera_desert_ABC.abc

Desert_v06.hipnc

Share this post


Link to post
Share on other sites

I will look at it when i get a chance but you can change the settings..the shelf always sets values like that by default

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×