Jump to content
alican

Collision field deleting the density field

Recommended Posts

I am making a smoke sim from the surface of a deforming object. And I want to use that object as a collision. But the collision field is eating my density field and I get a wierd result, density is disappearing when colliding. Is there any solution to this?

 

Thank you,

Alican

Share this post


Link to post
Share on other sites

in my experience this is often due to "collisionvel" field not being properly set up. this can cause problems especially if the collision object is moving quickly through the smoke volume. it will not transfer its velocities to the smoke vel field and will simply eat the smoke away

Share this post


Link to post
Share on other sites

Yeah I thought so but if I just want it to stick and slide on the surface it becomes much harder to achieve by adding extra velocity.

Share this post


Link to post
Share on other sites

By default the pyro/smoke solvers will clear any density which enters the collision volume in a timestep. I would double check your collision volume is interpolating sub frame and also that you are feeding the velocity from the collision object into the sim. On top of that depending on the speed of your object you may need to increase the substeps on the solver to help account for it. 

Also on the smoke/pyro solver if you go to the 'Advanced/Collisions' tab you can toggle off 'Correct Collisions' which will stop the solver from deleting any density which gets inside the collision somehow.

Hope this is helps

Cheers Jake.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×