Jump to content
Sign in to follow this  
PioRaffaeleFina

Attribute randomize issue

Recommended Posts

I just installed Houdini 15.5.683 for Ubuntu 16.04 and I gave a quick look to see how different was from windows version. The first issue that I encountered is with attribute-randomize sop, that gives me a strange error (VEX related). I tried the same setup in windows and everything works smooth! maybe is a ubuntu specific bug? there's someway to fix it, because this sop is essential to me. thanks in advance

ps. I navigated inside the attribute randomize sop to find the actual line error.

Schermata del 2016-12-17 00-25-11.png

Share this post


Link to post
Share on other sites

Is that the only node giving you problems? If multiple nodes give you problem maybe try to reinstall it. I just tried on CentOs and it works fine. I can't try on Ubuntu.
Maybe you can report it to SESI.

Good luck!

Share this post


Link to post
Share on other sites

Have you added LC_ALL = C to your houdini.env file? 

 

Share this post


Link to post
Share on other sites
3 hours ago, Hamp said:

Have you added LC_ALL = C to your houdini.env file? 

 

Yes but no changes, the error persist. As Diego suggest I tried some other SOP nodes and I noticed that the problem is only VEX related.

ps, what LC_ALL=C  supposed to do?

vex error.png

envVAr.png

Share this post


Link to post
Share on other sites

Houdini is sensitive to which locale (country specific settings, like whether to use  .   or  , in numbers etc) you use.

If you don't use English locale, the variable fixes a lot of strange errors that only occurs if you have a different locale.

Every time I have installed Houdini in Ubuntu with Swedish locale I had to use the variable to make Houdini work.

One question though.. why is your houdini.env called hodini.env? And otherwise empty? There should already be one in your $home/houdini.15.5 directory. 

Maybe that's the problem?

  • Like 1

Share this post


Link to post
Share on other sites
On 17/12/2016 at 6:37 PM, Hamp said:

Houdini is sensitive to which locale (country specific settings, like whether to use  .   or  , in numbers etc) you use.

If you don't use English locale, the variable fixes a lot of strange errors that only occurs if you have a different locale.

Every time I have installed Houdini in Ubuntu with Swedish locale I had to use the variable to make Houdini work.

One question though.. why is your houdini.env called hodini.env? And otherwise empty? There should already be one in your $home/houdini.15.5 directory. 

Maybe that's the problem?

In fact I'm using my own language settings on Ubuntu. I deleted hodini.env ( I didn't saw the type error!) and added LC_ALL = C to the right houdini.env and now everything is fine, no more VEX errors. Thanks a lot Hamp!!

Share this post


Link to post
Share on other sites

Yay! Glad to hear :)

I'm sure you will enjoy Houdini on Linux as much as I have.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×