Jump to content
Heraklit

FLIP collision madness

Recommended Posts

Hey,

I do have a little problem with flip collisions. I'm simulating a layer of caramel on top of which I want to add a layer of chocolate. The mesh of the first layer I converted to a deforming object. Collision volume and everything looks just fine. Unfortunately flip is going crazy when it touches this surface.

collision.png

Share this post


Link to post
Share on other sites

I wonder about the two FLIP solvers. Are their particle separations equal?

Share this post


Link to post
Share on other sites

The first flip solver isn't active because of the switch node. It just simulated the first layer of caramell.

Share this post


Link to post
Share on other sites

In the FLIP solver, try increasing the substeps and under volume motion, set the solver to the swirly kernel. You can also decrease the force scale and/or decrease the collision velocity scale. :)

Share this post


Link to post
Share on other sites
Guest tar

The Origin gnomon looks enormous, it's possible your scene scale is wrong.

Share this post


Link to post
Share on other sites

Its small, yes, but why did the first layer of flip caramel sim absolutely correct? If I let this chocolate layer collide with the bisquit it works fine again. Its something about the fluid collision layer.

I'm trying to recreate this sim I did with realflow some time ago. So one layer of caramell and one of chocolate 

I add the file if that helps. 

untitled.hiplc

Edited by Heraklit
  • Like 2

Share this post


Link to post
Share on other sites

Hi There

You've got friction and bounce enabled incorrectly for the caramel collision volume if you mean the splashy behaviour you're getting here.  If you look at the keks col vol you've got friction set up at 300 hence the diff behaviour.

Least I think that's it..  Haven't tried it out

 

cheers

Nigel.

Share this post


Link to post
Share on other sites

This seems to come up from time to time. The file above had too many errors when I opened it and it was missing some geo. Ideally you would want to get the two emitters in the same simulation together (if you can) for better interaction. To get two emitters with viscosity to work in the same simulation, you would just define your attributes in the sop level on your points using a wrangle. Just make sure you turn on the viscosity attributes on the flip solver.

The attached file is using the method the OP was using which was simming one fluid (in his case the caramel), caching that out, and surfacing it to use in a second simulation (the chocolate). The viscosity settings in this file aren't based on anything and I just put some arbitrary numbers in for now. It is extremely low resolution because I didn't want to have to go through all the caching out. You can go into the second dopnet and press play to see this working. The switches on the emitter are just my quick way of turning off the emitter (probably could of been a bit more procedural in that regard).

This should give you a start.

flip_emitters_RB.hip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×