Jump to content

Dropped Frames and COPs Cache

Recommended Posts

Hi, I'm just wondering if anyone else is experiencing weird behavior in COPs where some frames tend to drop? (shows up as black) And some frames even shows up as some sort of random lines. Resulting on my final render to have random flickers due to incomplete passes.

This is a capture of me scrubbing the timeline..

I'm using a VOP Cop filter that simply copies the Pz channel to R G and B:

I couldn't figure out a proper repo yet as it is occurring quite randomly. Sometimes, after a fresh scene, it would exhibit the dropping.. sometimes it won't.

I'm thinking that it is related to how COPs handles the image cache.. so I tried clearing/refreshing them with these methods:

  • Reload the File SOP.
  • Cleared the Compositing Cache from Edit menu.
  • Cleared the Cache from the Houdini Preferences Window.
  • Also Increased Cache Sizes. (Restarted Houdini)
  • Used python to clear out more cached elements:
    hou.hscript("glcache -c")
    print("Cleared GL Cache")
    hou.hscript("texcache -c")
    print("Cleared Texture Cache")
    hou.hscript("compfree -c")
    print("Freed Comp Cache")


I also noticed that it seems to be related to multi-channel EXR/PIC files.
I almost gave up on the scene that I'm working on and was about to jump to Natron:lol:.
But as a last ditch effort, I tried just rendering my scene as separate sequences per pass. (RGB, A, Z, Normal, etc..)
Finally when I rendered the comp, I got no dropped frames.

As soon as I can track down a repo step, I'll send an RFE to sidefx.

Do you guys encounter similar problems when using COPs?


Share this post

Link to post
Share on other sites

Are you using integer frames?

Share this post

Link to post
Share on other sites

Hey Atom, I re-opened my old scene, it is still flickering and/or dropping frames. I checked my Animation Options and I do have it on integer frames. I'll try and create a simplified version of this with the animated sequence, then send it to sidefx.

Share this post

Link to post
Share on other sites

Just updating this thread for those who may encounter a similar problem in the future.

As the anomaly seems to stem primarily from my use of VOP COP Filters, I got a suggestion from support to instead try and use a COP Input VOP instead of Bind VOPs for pulling other planes from any input. I will see if this alleviates the problem on my next venture into COPs.
They also mention that the bug is still being investigated. RFE #82228

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now