Jump to content
Sign in to follow this  
nicoladanese

prevent houdini going back to frame 1 when stopping flipbook

Recommended Posts

Hey

I'm wondering if there's a way of preventing houdini to go back to frame 1 when I interrupt a flipbook, I quite often launch flipbook to check sims and then stop to look at the sim from different perspective. I know I can write the cache but if there's a setting to avoid that it would be great I think...

cheers ;)

Share this post


Link to post
Share on other sites

Hey,

I have the same problem, I don't want to cache my sim (pyro in my case), because I do a lot of interaction and it's faster without writing the data on the disk and not enough memory to save a lot of frame (around 500f)

So every time I stop the sim and the flipbook I lose all the data in cache, it's very annoying, I can't check any value of velocity,density, temp,... neither see the pyro in 3D

Help ... thanks

Share this post


Link to post
Share on other sites

I've been having the same problem. I usually have to decide in advance what frame I want the sim to stop at, but it would be nice if I could cancel a simulation without it deleting the cache. Does anyone have a solution for this?

Share this post


Link to post
Share on other sites

There isn't a solution that I know of. You can try writing out .sim files, if you want to be able to cancel and resume a cache, or you can just skip the playblast part, and just click on that frame to sim to that point, then when you get to that frame, you will have a certain number of frames in a temporary cache that you can scrub through, without losing that data, until you go to a point before that cache begins - that cache will be the blue section on the timeline.

Share this post


Link to post
Share on other sites

The "Leave playbar at last frame" toggle in the Flipbook options will avoid jumping to the frame you were on before you started the flipbook (Houdini 16.5+).

  • Like 2

Share this post


Link to post
Share on other sites

It would be nice if these toggles were available under MPlay preferences. I can't tell you how many times I have flipbooked something which generates a completely valid cache only to have the cache disappear when I close MPlay to reset my view.

The clearing of the cache might be related to jumping back to frame #1.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×