Jump to content
Qwertzus

Alembic - Face ID Sets exported randomly

Recommended Posts

Hi!

did anyone experience the same issue?

I imported an Alembic file with different face IDs to Houdini. But when I export it back via Alembic just for testing the ID grouping is basically right, but they don't have the correct order/ID… , they are randomly distributed.
I cannot see any pattern. It's neither alphabetically nor based on face count.
My node tree consists of: Alembic Import Node –> ROP Alembic Output.

example.png
On the left side you see the original mesh with correct Material ID order and on the right side the imported Mesh with the wrong material order.

Does anyone has a solution for this? smile.png

Thanks in advance!

Share this post


Link to post
Share on other sites

Have you tried activating Build Hierarchy From Attribute or tried the other Partition modes?

Share this post


Link to post
Share on other sites

Thank you very much for your answer!

Yes I have tried this but no difference. I also tried renaming the materials in Max _0,_1,_2,_3, ... (relating to those video comments: https://vimeo.com/album/4473536/video/113366813) but without succes.
Maybe I have to do something with the prim groups that Houdini is importing from Alembic Face Sets?
Because they have the right order and the correctly selected faces. But I don't know how to handle them in order to export them correctly:


example_import.png

Share this post


Link to post
Share on other sites

ids1.png

Bottom = Original
Top = Alembic Export


I made a test with some primitives. If I stay under 9 IDs, everything is okay.

But when I have more it will mix them up...

Edited by Qwertzus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×