Jump to content
gigafrax

Slow moving flip causes mesh flickering

Recommended Posts

Hello guys,

i have a serious mesh flickering problem in my flip simulation.

The timescale in the flip solver has been animated to slow down the simulation. Looking at the particles everything seems fine, but when it comes to meshing and the particles are moving really slow, the mesh starts to flicker and holes are forming and disappearing every frame.

I've tried increasing the resolution, lowering the particle separation in the particle fluid surface node (or vdb from particle fluid, i've tried that as well), lowering the grid scale or the particle radius scale, the flickering changes but it never goes away.

any help is greatly appreciated

thanks in advance

slowmoving_flip_flicker.hip

Share this post


Link to post
Share on other sites

Yep, animated TimeScale and FLIP does have some issues. One thing I discovered back in H14 was that if you dive inside the flipsolver (allow editing of contents) you will find that there is a plethora of nodes that have a TimeScale parameter but fail to reference the top level TimeScale parameter in the flipsolver. Thus their value is a constant of 1.0, not your animated value. Some of them even reference the TimeScale value correctly but have their drop down set to Use Default, instead of Set Always. This means animated values will fail to be recognized on that particular node.

I have marked them all in bright yellow and installed the correct reference to the upper level TimeScale parameter.Untitled-1.jpg

Also I think your final resting value for the animated TimeScale value is creating a "beat pattern" against the 24 fps. The value your TimeScale ends up on is 0.3 which is a 3rd of a second I tried a value of 0.25 which is a quarter of a second and got a little smoother result. So you may want to play with that number or adjust your fps.

timescale_flip.gif

 

 

ap_slowmoving_flip_flicker.hiplc

Edited by Atom
  • Like 4

Share this post


Link to post
Share on other sites

Thank you so much Atom!

That fiddling with the solver's guts helped a lot, although not completely. At 0.03 timescale there is still some flickering going on. What i did (and i don't know why i didn't think about that earlier) is change the surfacing mode from "average" to "spherical" in the particle fluid surface node. That gets rid of any extra flickering but in gives the surface a slightly more blobby look...nothing that a little erode and smoothing can't handle.

Anyway, thanks so much for your help! I'm sure this will be useful to many

ap_slowmoving_flip_flicker_v2.hiplc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×