Jump to content

Recommended Posts

Hi all :)

I need help with Arnold for Houdini installation 

I have this problem , Please find it in the attached file 


Traceback (most recent call last):
  File "arnold_light", line 6, in <module>
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.557/houdini/python2.7libs\objecttoolutils.py", line 482, in genericCameraLightTool
    camlight = genericTool(scriptargs, nodetypename, nodename, clicktoplace)
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.557/houdini/python2.7libs\toolutils.py", line 1251, in new_func
    return function(*args, **kwargs)
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.557/houdini/python2.7libs\objecttoolutils.py", line 441, in genericTool
    exact_node_type = exact_node_type)
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.557/houdini/python2.7libs\objecttoolutils.py", line 379, in genericObjNodeGeneratorTool
    exact_node_type )
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.557/houdini/python2.7libs\objecttoolutils.py", line 320, in createObjNode
    exact_type_name = exact_node_type)
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.557/houdini/python2.7libs\houpythonportion.py", line 1287, in decorator
    return func(*args, **kwargs)
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.557/houdini/python2.7libs\hou.py", line 6585, in createNode
    return _hou.Node_createNode(*args, **kwargs)
MatchDefinitionError: Failed to match node type definition.
Error:       Bad node type found: arnold_vopnet in /obj/arnold_light1/shopnet.
             Bad node type found: arnold_light in /obj/arnold_light1/shopnet/arnold_vopnet.
Warning:     Ignoring data for locked node: arnold_light1/shopnet/arnold_vopnet/OUT_light
             Ignoring data for locked node: arnold_light1/shopnet/arnold_vopnet/OUT_light
             Ignoring data for locked node: arnold_light1/shopnet/arnold_vopnet/OUT_light








Node lock.jpg

Edited by salah_hussein

Share this post

Link to post
Share on other sites

Hate to revive thread, but don't see reason to start new one, since I have this error as well but more so it's related to anything arnold in Houdini.

(This is just unlicensed arnold for now)

Having issue with Arnold to Houdini Indie. Windows 10. Houdini 16.5.439. Arnold = htoa-3.0.1_r0f08864_houdini-16.5.439_windows

I can't seem to get past this issue after many many hours.

Things that are weird are some filepaths in that error have mismatched forward and back slashes. I wasn't sure how to fix that or why it would do that in the first place.


I have redshift, but I'm not going to add path just to keep things simple. Python I added just in case it was sourcing incorrect python version.. doesn't change result of error.

Other issues that may be similar are something to do with the visual studio side of things. tried uninstalling visual studio 2017. reinstalling 2017, uninstalling 2015, installing 2015. 


adding DSO error check in env variables = Houdini DSO error will say (127) Couldn't load. C:/Users/Max/htoa/htoa-3.0.1_r0f08864_houdini-16.5.439/htoa-3.0.1_r0f08864_houdini-16.5.439/dso/htoa_core.dll.   This is probably because this file was intended for use with a different version of houdini (yet the versions match up less I'm crazy.)


# htoa config start
PATH = "$PATH;C:/Users/Max/htoa/htoa-3.0.1_r0f08864_houdini-16.5.439/htoa-3.0.1_r0f08864_houdini-${HOUDINI_VERSION}/scripts/bin"
HOUDINI_PATH = "C:/Users/Max/htoa/htoa-3.0.1_r0f08864_houdini-16.5.439/htoa-3.0.1_r0f08864_houdini-${HOUDINI_VERSION};&"
# htoa config end

I've also tried hardcoded versions of the path and houdini paths





I've tried multiple reinstalls of houdini and arnold as well as multiple versions of each. If anything I'd like a way to reset everything and not have this problem at all lol. I've installed it on a friends computer just fine, so not sure why I'm messing stuff up.

Thanks if anyone knows any solution or ideas. I've had a few people try to help and am very grateful.

few ideas were to check vcredist_x64.exe and install that. which I already had unfortunately so thats the whole visual studio stuff. and check my script error locations and see if they were in read only - they were not and they had full privileges.




Edited by MaximumsProductions

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now