Jump to content
lemmingsammy

keep uvs on flip anim

Recommended Posts

So I have a very simple build, consisting of a flip tank and a flip solver with a custom volume velocity plugged in. I'm trying to keep the uvs after converting the points back to a VDB but they don't seem to be coming across correctly. Im using an attribute transfer to transfer them back. Anyone know why?

 I have Attached project
ThanksUV_FLIP_TEST.hip

Share this post


Link to post
Share on other sites

Check this masterclass, Jeff talk about that here

Around 1 hour and 20 min

 

Share this post


Link to post
Share on other sites

Thank you so much for your reply. This isn't exactly what I'm looking for as the uvs don't stick to the particles mesh when moving they just distort ever so slightly. Also alembic exports don't recognise the uvs with this method.

 

The current method (project file) i've got is by assigning the uv onto the points before the sim then reassigning the uvs with transfer attribute... this doesn't work either though

Edited by lemmingsammy

Share this post


Link to post
Share on other sites

Check out this link. I had to do this a short while back with melting an object using FLIP.

Share this post


Link to post
Share on other sites

Thanks for the reply!Hi this method only works if using the shelf tools. As i have a custom flip fluid this method doesn't work for me. I hate to ever ask but i don't suppose you have a project file of yours too look at. Ive been tearing my hair out for about 3 days trying to work this out. arrrgggghhh

Share this post


Link to post
Share on other sites

Having some issue regarding pre-existing UVs (for example any alembic exported from maya or even pighead)

 

I tried @Atom method of promoting UVs to points and again transferring it back to the vdb mesh. This works fine for default geometries but doesn't work when testing with alembics.

I am attaching a test file for the same, please have a look.

flip_UV_transfer_001.hip

Share this post


Link to post
Share on other sites

You need to unpack Alembic before you begin processing. Here is a revised setup using a .abc file. There were some errors in your file.

There are some UV anomalies, but if you increase the FLIP resolution (which is matched to the pointsfromvolume resolution) the anomalies become less obvious.

 

Untitled-1.jpg

mb_african_femal_01.abc

ap_flip_UV_transfer_001.hiplc

Share this post


Link to post
Share on other sites

Hey Atom,

Sorry I got busy with some stuff and could not reply here. The setup worked smoothly, thanks a lot! 

The only issue which is bothering me and I think most of us is the UV sim issue. There is a paid tutorial which claims to have fixed that, I hope someone could explain it here.

Cheers!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×