Jump to content
WhyGee

cloth collision radius has no effect (16.5.323 Indie)

Recommended Posts

Hi,

Has anyone else noticed that the cloth collision radius has no effect on actual collision distance? No effect on cloth to cloth or cloth to other collider types.

I would appreciate a confirmation and of course a workaround if anyone has managed to find one. 

Thanks

Share this post


Link to post
Share on other sites

Go ahead and post your broken file, or a small example of cloth collision failing. Remember to include the collision geometry if it is file based. CTRL-Click on the File node to lock the content into the File node and make it portable with the HIP file.

Edited by Atom

Share this post


Link to post
Share on other sites

so sidefx marked this is a bug. But if anyone has a workaround meanwhile, I'd really appreciate it. 

 

Thanks

Share this post


Link to post
Share on other sites

Yeah, a single flat face colliding with a single flat face is a difficult code solution. What helps out the code is if you give the collider some volume. Try replacing your Grid with a thin Box. Adding a slight rotation to one of the planes can help too. This way you are not colliding perfectly with one plane to another. One side will hit sooner than another. Also the cloth solver likes triangles better than quads. Try scaling up or down the simulation. In this case I scaled everything up by 10 and the simulation worked. When I ran it at 1x scale, there was interpenetrating cloth. You can always scale it back down after the simulation has completed.

cloth_drop.gif

ap_cloth_collision_test2.hiplc

Edited by Atom

Share this post


Link to post
Share on other sites

Hi Atom,

Thanks for the scene. The 2 grids in my sample hip were just to show the problem, the actual scene is far more complex.

Support has confirmed that this is a bug. In the documentation they explicitly advice against adding thickness to cloth by extrusion and to use the collision radius instead. This does explain the poor collision behavior in houdini's cloth and the extreme substeps required to get something somewhat useful but it's never really close to the speed and accuracy of other solvers. 

I've just tried in Houdini 16.0.633, same behavior. A bit surprised that noone flagged this bug before. 

Share this post


Link to post
Share on other sites

I am also having issues with this collision radius and collisions in general I couldn't find a way to get multi layered cloth work smoothly in any way in the matter of fact I couldn't at all I always get inter penetrations and jittering and no matter what value I put on the collision radius nothing changes, anyone else having this issue on 16.5?

Share this post


Link to post
Share on other sites

Still waiting for sidefx to fix the bug. Ill email tomorrow to see if i can get an ETA. Hopefully this will make houdini's cloth usable again

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×