Jump to content
Sign in to follow this  
Blacko0ps

Collision object in Pyro sim

Recommended Posts

Hi everyone,

I am working on a smoke simulation and i have imported my collision object with source volume into my Pyro sim. No matter how much I increase the smoke divisions as well as reducing the voxel size on colliding geometry I still get jagged edges when smoke interacts with it. I have attached a screen capture here to make it more clear. Is there any way to smooth the jagged edges or am I missing something in the process? Any tips would be greatly appreciated!

Screen capture.JPG

Share this post


Link to post
Share on other sites

Try dropping down a GasBlur inside the DOP network and plug it into Velocity Update on the solver. Set your field to density and increase the radius until you see an effect.

Share this post


Link to post
Share on other sites

Thanks man, but it seems like blurring out the smoke more than the colliding section. Is there any other solution to that?

Screen capture2.JPG

Edited by Blacko0ps

Share this post


Link to post
Share on other sites

Can you post the scene?

Maybe try a better font..?

Share this post


Link to post
Share on other sites

You should take a look at your collision in your solver . 

Go to your static object if you using it . Tab collision RBD solver Volume , and display collision guide . Should be blue mesh . See what it look like .

Share this post


Link to post
Share on other sites

Its you collision geo you culd do a polyreduce  and use :

Continue Reducing with quality Toleranceand Use only Orignal Point Position so yiou get better geo , 

 

and also you  should probably use the logo as a holdout when render this right? 

Share this post


Link to post
Share on other sites

Try a lower division size.

Your posted scene reports 11 million voxels. This image shows 21 million voxels and less jaggies. So the collision aliasing is reduced as the simulation quality is increased, by lowering the PyroObject division size.

To get an idea on how many voxels you need, consider that ILM used 65 million voxels for preview quality work and 165 million voxels for final explosion work on the Transformers movie.

 

 

Untitled-1.jpg

ap_smoke_test.hiplc

Edited by Atom

Share this post


Link to post
Share on other sites

Oops! that make sense, thanks a lot man! I may need to consider buying a new tower for that as it's taking so long to simulate with 11 million voxels

Share this post


Link to post
Share on other sites

Check out my posted file. I rebuilt your setup and it runs a little faster..less nodes. Also if you have some vRAM available, 4GB+ try enabling OpenCL on the SmokeSolver (Advanced TAB) for a modest speed increase.

Share this post


Link to post
Share on other sites

I don't have limited commercial edition at work. Gonna check it out at home later on tonight. Cool, I will enable that. Also seems like increasing substeps on Dop Network helps to smooth out that jagged edges too 

Edited by Blacko0ps

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×