Jump to content
Hunter Williams

scaling RBD sim problem

Recommended Posts

Posted (edited)

Hey guys! 

Hoping you can help me out with this. Trying to get this RBD sim to time properly, tried even scaling the scene in the HIP file for the DOP network to have best avail information. Density should be pretty accurate for steel as well.

The sim feels like its going in slow motion / in space / another planet- gravity feels very low even though its definitely the correct -9.8m/s^2. Should I just speed it up post- cache? Or is there some option I'm not looking at.

Pretty new to Houdini, so let me know what y'all think / any other suggestions? Thanks!! :)

F150_body_metal_v01.abc

preview_cache_v01.mov

180505_hardConstraintTest_v07_metal_only_slide.hiplc

Edited by Hunter Williams
changed tags

Share this post


Link to post
Share on other sites

check the scale of the objects. If objects bidder then in real life you should increase all forces and masses in sim to fit for real life. Basically work-flow very simple: before dop your objects should be in real scale, then you can scale up for 2 or 3 times objects before dop, to avoid weird behaviour of the very small pieces, and you should scale gravity and all other forces in DOP, as well as mass or density of the sim objs, the same value. After sim scale down. Or try to sim in real size firstly.

Share this post


Link to post
Share on other sites

The objects are way too big. One unit of distance in Houdini is equal to one meter. So that truck is half the size of a football field in the video attached to your post.

Share this post


Link to post
Share on other sites

Luke and tamagochy - thanks for the replies!

I did scale my project in the HIP file options to one unit being .1 meter- and the truck is apprx. 40 units long, so in the above video its about 4 meters long. I'll try to scale it without using the HIP preferences, but just using a transform and see where that gets me.

Thanks!

Hunter 

Share this post


Link to post
Share on other sites
48 minutes ago, Hunter Williams said:

Luke and tamagochy - thanks for the replies!

I did scale my project in the HIP file options to one unit being .1 meter- and the truck is apprx. 40 units long, so in the above video its about 4 meters long. I'll try to scale it without using the HIP preferences, but just using a transform and see where that gets me.

Thanks!

Hunter 

Did you change that preference before or after you created the sim? It doesn't change existing nodes, only ones created afterwards. Think of it more as a global default. Set the preference to 0.1 and drop down a Gravity DOP and see what happens. Now set it back to 1 and drop down a second Gravity DOP.

Share this post


Link to post
Share on other sites

@Skybar I did change it after I created the nodes!

That 100% solved it. Dropping down a new gravity node after scaling in the HIP file options did the trick- I thought I just had to restart the sim!!!

 

Thanks!

Hunter 

Share this post


Link to post
Share on other sites

Bad idea to change scale in hip preferences, better use transform node instead.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×