Jump to content

FLIP - sourcing from points

Recommended Posts


I used shelf tool FLIP fluid from object. Then in sops I chaged mu source to just some points generated by popnet, removed all attribs from source. Then I just in FLIP object changed the input to particle field.

And everything is nice and dandy, except when I go highes. I noticed that when I add more resolution (add particles, so decrease particle separation) my particles start do dissappear.

Every couple of frames all particles are beeing removed. I thought that its because I use popnet as a source, but actually I removed all attribs.

So I guess FLIP does not like to be sourced like that. The way I "fixed" it is more particles for source (like 1000x more!). Which is not an actual fix, because will be super slow when I really go super heavy highres.

So how do I properly setup to source FLIP from points? But not using fluidsource

Share this post

Link to post
Share on other sites

Hard to say without seeing your file but if you have reseeding turned on it's possible decreasing particle separation is causing reseeding to remove particles. try turning it off and see what happens.




Share this post

Link to post
Share on other sites
Posted (edited)

by default the reseeding expects 8 particles per voxels, the 0.5 and 1.5 values are thresholds.
if there are less than 4 particles per voxel (8 * 0.5) new particles are created.
if there are more than 12 (8 * 1.5), some get deleted.
so you can turn off the reseeding...

here is a simple example, with lowres flip, more resolution in the source only, and a fix by turning off reseeding:



Edited by bunker
  • Like 3

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now