Jump to content
akaliln

velocity field question

Recommended Posts

hello guys, I tried to get velocity field in to POP and use  advect by volume. but particles stop moving when they reaching some position. I can't find the reason of it and how to fix it. Does anyone can help that for me please?

vortex_field_problem.hipnc

Edited by akaliln

Share this post


Link to post
Share on other sites

Not an expert but I think your particles stop when they reach the limit of the velocity field, and they reach this limit because your velocity is "pointing" outwards, so maybe transform the normal orientation before converting it to vel ?

Share this post


Link to post
Share on other sites

Hey, I took a quick loop at your hip file. I think it might be because the particles are going outside of the cone shape where the velocity is zero (and hence stopping).You could try creating a bigger velocity field and see if it fixes it

Share this post


Link to post
Share on other sites

hello Stephen Moroz thx for reply.

i just found out why particles are stopping. the one of them just like what you did mentioned about. the particles are out of volume. and I tried change particle footprint to velocity trail. Particles start moving better after that. 

but im still trying to understand why it works. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×