Jump to content

Recommended Posts

Hello,

I know it is basic question but I still think that there is a confusion.

What is the workflow to bring whole bunch of models from 3ds max(or any 3d package) to houdini with textures? Because we cannot relink the textures in houdini by hand, it will be very very time consuming.

Or I think there would be a script out there to relink materials after importing them in houdini.

Thanks.

 

Share this post


Link to post
Share on other sites

i don't think you can easily transfer texture assignments between 3d applications. there is currently no established framework that supports that kind of data exchange. fbx can sort of transfer materials but only in a very primitive way that isn't really suitable for any serious production

in general, you should do a texture assignments in the same application where you plan to do lighting/rendering, unless you've got data exchange solution ready beforehand.

 

Share this post


Link to post
Share on other sites

Thanks for reply Davpe,

As I have ready models with vray materials, so I am doing environment rendering in 3ds max and all fx(fluids,effects) in houdini with same camera animation.

But now I am facing another BIG problem.

1.When I import objects in houdini from 3ds max(alembic format), they seems to be very big. So, can you tell me where i am going wrong.

2.Is there any good way to give all models a matte shadow material in houdini? so that they can do their work in fx simulations and affects the lighting but they will not be rendered. In this way I can put 3ds max rendered environment exactly on that place.

Thanks.

Edited by Nsingh

Share this post


Link to post
Share on other sites

1. 3ds max and houdini has a different default unit scale. you have to compensate by scaling the scene/objects after import to houdini accordingly

2. on mantra node you can put objects into force matte or force phantom fields. that makes specified objects only be visible for secondary rays (with their alpha hold out if you render them as force matte) . if you want to override materials on bunch of objects, use Style sheets (sidefx has released pretty good tutorials on those)

 

 

Share this post


Link to post
Share on other sites

you might also consider rendering all in 3ds max. If you have materials on your objects, and you are rendering water, you probably want those materials with textures be visible in refraction in water.

In that case, would make sense to render in app, where you have those textures applied. if that's possible of course.

 

Share this post


Link to post
Share on other sites
1 hour ago, martinkindl83 said:

you might also consider rendering all in 3ds max. If you have materials on your objects, and you are rendering water, you probably want those materials with textures be visible in refraction in water.

In that case, would make sense to render in app, where you have those textures applied. if that's possible of course.

 

True, but is there any good way to bring houdini fx in 3ds max and render it there.

I know houdini engine. Is it capable of transferring millions of particles?

And which render engine shoud I use to render fx in 3ds max?

One more question: What if I take models with redshift materials from 3ds max to houdini and render it with redshift. Will redshift materials be still there or not?

Edited by Nsingh

Share this post


Link to post
Share on other sites

No, the Redshift materials will not be there. If you export your city as .obj, a companion .MTL file should be generated by 3DSMax. You can then run my script on the .MTL file to re-generate a close match of the Reshift material inside of Houdini.

NOTE: There are some differences between 3DSMax and Houdini worth noting. In 3DSMax a material can begin with a number, (i.e. 001_my_mat). This is an invalid name inside of Houdini. Houdini can not have any node name start with a number. The link does contain a fix-up script to handle such cases but it might be simpler to review your material names in Max before you export and simply rename any "bad" material names to match the Houdini requirement.

 

Edited by Atom

Share this post


Link to post
Share on other sites

I am not sure about 3ds Max, but in general, you can transfer geometry from Houdini to another 3D package with Alembic and volumes with VDB (so you don't need particles, but in case you need them, Alembic is also a way to go).

If 3ds Max is your primary package then render your scenes there and do in Houdini only FX and export results as volumes or geo, this is a quite common workflow. If you have a 3ds Max scene which you would like to use in Houdini and complete the rest of production there its also possible, for example via FBX. Just make some test with a small portion of data (one building instead of the whole city) and see what you get. It's hard to advise a high-level workflow without knowing all your project details and resources.

Redshift materials from Max to Houdini via FBX should work, the issue you may face is a paths to textures.

Share this post


Link to post
Share on other sites

I was faced with the same issue here recently. I decided to just do my sims in H and export as VDB's to maya for rendering. 

Which worked out great. Just as other have said make sure you scale your geo correctly on import.

Share this post


Link to post
Share on other sites

Yes we can export fx as vdb from houdini but the stuff like ocean spray, whitewater are not rendered good in other 3d applications.

Share this post


Link to post
Share on other sites

Can someone just tell me that why I am getting this big splash when tsunami(fluid) collide with static cars and also this weird big bunch of droplets spreading after collision. I tried all the settings (surface extrapolation, velocity scale, spatial scale, surface tension, etc) but nothing changes that.

I also visited all the threads similar to this topic but none of them ended with a good solution. Kindly have a look on the attached screenshots and suggest any solution to decrease that splash.

Thanks.

Forum_Question.png

Forum_Question_2.png

Share this post


Link to post
Share on other sites

My guess is your collision mesh is too low of a resolution.

Share this post


Link to post
Share on other sites

Thanks for the prompt reply,

Here are the screenshots my collision guide and it is set to 0.03. and actually by decreasing the force scale I am getting good results of splash but there are still these large water droplets. So, can you suggest something to get rid of them.

And my particle separation is 0.02.

 

F_q_3.png

f_q_4.png

Share this post


Link to post
Share on other sites

The blue collision guide is for RBD, try turning on the Collision guide on the FLIP Object, it is displayed in magenta/purple and grows in scene space as the fluid touches it. The way FLIP collision works is it takes the BLUE VDB and resamples it using the particle separation value to generate it's own collision surface. As you lower your particle separation, you increase the resolution of the FLIP collision surface as well. You can "de-couple" them on the FLIP object, but they are linked by default.

I can tell by your screenshot that you still need to lower your particle separation.

Also select the FLIP Solver, move your mouse into the 3D viewport and press the ENTER key. This will cause a RED box with handles to appear. This is your master flip domain size. Try to tighten it up as close as possible to what is visible in your camera view/shot. This domain/area is the area divided by particle separation, so as you tighten it up, you get more "quality" out of the same particle separation value. This is why there are no "magic" numbers.

Edited by Atom

Share this post


Link to post
Share on other sites

Yes my collision guide on flip object is also nice but now the problem is not collision, its that big droplets that I am getting in the simulation.

Do you mean that droplets can go away by increasing the particle separation? If yes what should be the particle separation. And if I decrease it below 0.015 then it will take very long time to simulate.

Share this post


Link to post
Share on other sites

There are a few factors to consider, reseeding does help with surfacing. But lower particle separation will also help improve surfacing. On the particlefluidsurface node try lowering Influence Scale closer to Droplet Scale (but don't go lower than droplet scale as tool tip warns).

There is no magic number, there is only voxel count.

Create a new float parameter on the flipobject and paste this expression into the new float field.

ch("../flipsolver1/limit_sizex")/ch("particlesep")*ch("../flipsolver1/limit_sizey")/ch("particlesep")*ch("../flipsolver1/limit_sizez")/ch("particlesep")

This will give you a voxel esitmate. Now when you change the flipsolver area or the flipobject particle separation, you can observe the number of voxels occupying the total area. Ultimately the quality of your FLIP sim is directly related to the amount of RAM in your computer. You can not exceed physical RAM or simulation times become too long.

If you can post a version of your scene I'll take a look at it.

Edited by Atom

Share this post


Link to post
Share on other sites

I will implement your suggestion and if I got stuck somewhere, I will post it.

Thanks for your prompt replies.

Edited by Nsingh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×