Jump to content
Man

separate mplay for each houdini session

Recommended Posts

The core problem is this: our artists will sit in front of a computer, then go home and use the same computer over vnc (using separate Gnome sessions in Linux).  If they have Houdini running in each, the second Houdini will push images to the first mplay--which they can't view.

The same thing happens if you run 2 Houdinis on a single desktop, they both push images to 1 mplay session.  This is the behavior I get in Linux and macOS.

The only workaround I have is to kill the first mplay.  Is there another way I can get Houdini to push to separate mplay sessions?

Share this post


Link to post
Share on other sites

This also seems to happen when multiple users are using Houdini on the same box--which is very problematic.

Share this post


Link to post
Share on other sites

In your flipbook options, just add a session name, make it different for each of your Houdini sessions and they'll all go to seperate Mplay windows.

houdini_session_name.png

Share this post


Link to post
Share on other sites

You can also hit disconnect at the top right. Next flip books will open a new mplay.

Share this post


Link to post
Share on other sites

Thanks for the replies!

@br1 Setting a Flipbook Session name does exactly what I was looking for.  There's even a preset to use the pid.  I'm not seeing a similar preference for Renders--is there one?

@ejr32123 Is this in mplay?  I saw that under Render > Disconnect, but the mplay session would be on another screen.  Is there a way to do this from Houdini?  

Share this post


Link to post
Share on other sites

Do you mean you want this to be available for rendering ?

I usually render to disk and open them later using different mplay sessions, or I just render to the render view. Rendering to disk is still the safest option.

Share this post


Link to post
Share on other sites

You can manually open mplay on the screen you want then hit render > listen for renders

Share this post


Link to post
Share on other sites

@br1 By clicking "Render to MPlay" on the mantra node.  Using Render View is an option I'll pass along, but I'm trying to support their current workflows, if possible.  The flipbook preference is great because I can just set that in the background and it starts working how they would expect.

@ejr32123 Unfortunately, if select "listen for renders" in a second mplay session, renders still go the the first.  The only way I can stop it from going to that original mplay session (the user cannot see or access) is to click render > disconnect before hitting render > listen for renders in a second mplay or killing the first mplay process.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×