Jump to content
nicoladanese

static gas turbulence?

Recommended Posts

Hey!

I'm trying to get a very low freq turbulence in my smoke trail sim, but even if I put pulse length to a very high number, 10000, the turbulence keeps moving with time, while I want some sort of static turbulence to break my trail line..any idea?

cheers

Share this post


Link to post
Share on other sites

Here is something that might help. Create a temperature field (or create a scalar field). Make it so the temperature field (or scalar field) dissipates.  Set the temperature field (or scalar field) to be the control field of the turbulence. Set control influence to 1. If you are using temperature make sure to turn off buoyancy. After the temperature or your scalar field dissipates the turbulence will stop. That way there will always be more turbulence near the source and it will fade off.

Edited by ejr32123

Share this post


Link to post
Share on other sites

Hey Evan!

thanks for your reply, but I'm not sure I explained myself correctly, I'm looking into a way of keeping the velocity vectors of the turbulence static, at the moment they move, the help says to increase the pulse length but they still move, slowly but still moving...

Share this post


Link to post
Share on other sites

oh, can't you just set the pulse duration to 0? Try the same thing with fluid source node. hit use noise. You will see it start to move. Set pulse duration to 0 and it stops completely.

Share this post


Link to post
Share on other sites

hmmm weird, in the fluid source pulse at 0 kepps the noise static, but in the gas turbulence node looks like the pulse lenght is not connected to anything, this flipbook was made eith pulse at 0

 

Pulse(001-240).gif

Share this post


Link to post
Share on other sites

change timescale to .2 or .1 in gasturbulence and pulse set to 5 or higher

Share this post


Link to post
Share on other sites

okay so looks like I found a solution, I had to activate open cl, then dive inside the gas turbulence and looking at the code in the compute_turbulence_cl time was just multiplied as it is, in fact no further math is applied to consider the pulse length...so manually changing time to 0 did the trick of having a static turbulence...not sure if it's a bug, will flag that to sidefx

Share this post


Link to post
Share on other sites

I have noticed that some of the OpenCL code is hard coded at 30 FPS which can create beat patterns against the default 24 FPS.

One thing you might want to consider is custom drag.

Check out Fencer's setup.

 

Edited by Atom

Share this post


Link to post
Share on other sites

Hey Atom, thanks!

I opened a ticket and sidefx asked for a scene to investigate...will update here asap

here the issue is double I'm afraid, in the CL code time is just as it is, with no reference to a multiplier, but at least I could modify it to suit my need, without openCL I did not find a way to make it work... 

Share this post


Link to post
Share on other sites

If all you want is a static noise field for the pyro to swim through, you can just use a curl noise in a gas field vop. If you want, you can just copy and paste the one inside the Gas Turbulence microsolver inside "compute_turbulence".

Inside the gas turb, it uses a vec4, with the fourth component after the position vector being time. So it doesn't matter if the pulse duration is off, it's still moving through time by default, because pulse duration is connected just to the offset parameter. You can unhook this and just use pos (vec3) to drive the position of the noise and run your pyro through it. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×