Jump to content
Yundaz

Flip Fluid Jittering when colliding?

Recommended Posts

Hi there.

 

I've got a basic thick viscous flip fluid simulation, problem is when it interacts with an Alembic with many holes the fluid seems to jitter alot and

the sim seems to splash outwards.

I reckon this is because of the change in the polygon count?

This is my Hip file and the Alembic (hopefully not to big to be on this forum) if so I can upload it to dropbox.

Hope you can help me out with this one.   (also added a clip)

Thanks,

Y

Fluid_sim_Test7.hip

testAlembic3.abc

JitterProblem_01.mp4

Edited by Yundaz

Share this post


Link to post
Share on other sites

You really need waayyyy more voxels than that to do a FLIP sim. Overall your setup is good, I tweaked the Collision generation a bit and the shifting geometry should not be a problem. I time stretched the Alembic and delayed the initial change while adding a trail to compute the velocity. This way each time the geometry shifts, you get a little kick out of the flip. Just disable the node if you don't want that.

Inside the DOP I added an additional hi-res FLIPObject that you can plug in for a more realistic simulation. It is set to 68 million voxels, compared to the mere 79 thousand found in your uploaded file. The preview FLIPObject is set to 1/2 million which gives reasonable response on most video cards. Hi-res will take a lot longer but your surfacing should look better. I also enabled Reseeding and turned up the Surface Oversampling to help smooth out the surface.

ap_Fluid_sim_Test7.hiplc

Edited by Atom
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Hey Atom,

 

Thanks alot for this! you the man.

Would love to know how you got the Voxel Estimate inside the Flip object too.

I'm caching this now and hopefully its all good now without the jittering occurring.

I have a more denser alembic file top which I will test later with this setup.

 

Question, So adding in the trail will compute velocity. So the fluid will interact with it more precisely ? or what does this do?

Would you be so kind to tell me what reseeding does? I've read about it but keep hearing lots of different theories. 

Keep you posted.

 

Share this post


Link to post
Share on other sites

The voxel estimate is just an expression calculation. It takes the box size of the sim and multiplies it by the divsize. If you left-click on the label titled "Voxel Estimate" on the FLIPObject you can review the expression code. Click again to toggle back to the result of the expression.

Check out Dave's short video on reseeding.

https://www.sidefx.com/tutorials/houdini-flip-quick-tip-abusing-reseeding-for-better-small-scale-viscous-sim-meshing/

 

Basically reseeding reviews voxels per frame. If some voxels have too little particles, more are added. If some voxels have too much, some are removed. It tries to achieve a density balance. But this does cause point count to change so that is why you may not want to use it in some cases.

Edited by Atom

Share this post


Link to post
Share on other sites

Thanks for that, exported a flipbook with the file you send as a high sim. I'm still getting problems, perhaps the velocity is changing drastically when polycount is going up on an alembic ?

Have a look at the video, its a pretty funny result but not what I was going for.

Also added in the hip file.

 

JitterProblem_02.mp4

 

ap_Fluid_sim_Test7_2.hiplc

 

Share this post


Link to post
Share on other sites

Updated my files with the velocity on the collider turned off.

However, I'm still getting weird artifacts in a more denser final alembic file. which is this one 

https://www.dropbox.com/s/kyhzuiq7mh1sn7e/NoiseBuild_reduced.abc?dl=0

 

Idea is that the thick fluid should fill the entire noise block almost like thick honey.

 

I've tried stepping up the separation pretty high but even that didn't help ( 10 million voxels ) also tried playing around with the reseeding Surface oversampling to 60 which helped a bit but not much.

I was hoping with the simpler (smaller file size alembic) I made, it would fix this one too but because its a lot denser it seems like not entirely.

Anybody have any ideas left or know whats up? 

Fluid_sim_Test9_solver.gif.defea6bba4fb11c12349edbbe791082f.gif

 

Thanks for your time and effort.

 

Fluid_sim_Test9_solver.hip

Share this post


Link to post
Share on other sites

That seems to help yes, but still looks like the liquid is is dancing.

(with slip on)

2018-08-27_22-54-05.thumb.gif.8f1c5ef315fad4607d34b44ad5011c67.gif

Share this post


Link to post
Share on other sites
1 minute ago, pxptpw said:

All the above posts are correct , made a few changes to your file , hope this helps

 

Fluid_sim_Test9_solver_mod.hiplc

Webp.net-gifmaker.gif

Amazing, could you tell me what you did please? just so I'm not missing out and for future reference.

Share this post


Link to post
Share on other sites
1 minute ago, pxptpw said:

All the above posts are correct , made a few changes to your file , hope this helps

 

Fluid_sim_Test9_solver_mod.hiplc

Webp.net-gifmaker.gif

Amazing, could you tell me what you did please? just so I'm not missing out and for future reference.

Thanks alot.

Share this post


Link to post
Share on other sites

if it helps that's great,

nothing out of the ordinary , just fixed the density and viscosity values and changed the velocity volume values in the flip solver, side effects has done a great job on h16 ,

so for most situations everything should be stable enough , have the sticky in the hip file 

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks, Pxptpw.

I guess turning on the friction and bounce in particle motion behavior helped too.

So my values in viscosity and density were way of I imagine.

Is this mainly a testing and looking thing or are there some good rules/tips to keep in mind for setting up the Density and viscosity.

Like viscosity should always be less then density or whatnot? 

 

Share this post


Link to post
Share on other sites

THE MYSTERY CONTINUES 

 

So I've used pxptpw setup and wanted to increase the particle separation for a nicer resolution result so it would flow better between the edges.

It is definitely better than my first version when the fluid exploded everywhere but when increasing resolution jittering and noisy flip fluid is back!?

How can I have a smooth clean sim with a higher resolution without noisy fluid and jittering artifacts happening?

 

By the look of the next image, I'm starting to think that the flip fluid isn't detecting the collision very well.

It starts to collide in a noisy way while there is nothing to collide with?...   perhaps this is what the main problem is, I just don't know how to go about and fix that.

Any ideas?

 

5b85c45764302_houdinijitteringproblemfluid.png.f76326651fc751cfb0f5ca3c08fd1a1c.png

 

In the gif here you can clearly see it,  also in the left section between the geo the fluid is jittering really crazy.

 

 

Alembic file download: https://www.dropbox.com/s/kyhzuiq7mh1sn7e/NoiseBuild_reduced.abc?dl=0

Hip file:

Fluid_sim_Test9_solver_mod3.hiplc

 

Thank you.

 

2018-08-28_22-59-32.gif

Share this post


Link to post
Share on other sites

not sure if this is the situation but viscous fluid don't collide really perfectly.

 

Check it out, the collision mesh is perfect and looks really nice when it's not viscous:


z0kY0jK.jpg

Maybe give it a try without viscosity to see if the problem goes away

Edited by ParticleSkull

Share this post


Link to post
Share on other sites

Hey Yundaz,

for speed purpose redused the emitter size

did not look at your latest file, but reduced the particle separation to .01 , and made some changes , see if this is what you are after, the collision voxels were a bit larger than the collider obj 

Fluid_sim_Test9_solver_mod2.hiplc

flipGif.gif

Edited by pxptpw

Share this post


Link to post
Share on other sites

Hey pxptpw

thanks for this, I liked your previous density and viscosity more which is more inline with what I need but it still Jumps (jittering) particles still act weirdly in that scene, especially when increasing the particle separation.

seems like there is no way to fix it without having that effect going or not having such a viscous fluid.

 

Share this post


Link to post
Share on other sites

Hi Yundaz,

gave a quick stab at your scene, see if this works for you ,adjusted the collision geo with the same viscous fluid you had and seems to work without any collision artefacts , reduced the velocity scale in the collisions , volume motion tab in the flip solver,

but mainly this reacted well as soon as the collision vdb were scaled to the right size as the collision geo, and any minor artefacts i reckon could be reduced with the meshing adjustments 

 

Fluid_sim_Test9_solverMod3.hiplc

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×