Jump to content
Sign in to follow this  
JJ FX

No shadows with shadow map lights

Recommended Posts

Hi,

So when I save the image with lights shadow option to depth map shadows, I get no shadows at all. Ofcourse this renders fine inside houdini, only saved images have that.

Ray traced shadows on the left and shadow map on the right

raytraced_shadowmap.jpg

Edited by JJ FX

Share this post


Link to post
Share on other sites

Have you opened the shadow map .rat file and checked what's stored in various channels? Is it just black or is there some strange looking data? You can also use viewport mode "look through light" in order to verify that the object is in the light's field of view.

BTW in order to get Mantra to use shadow map in the IPR renderer you need to attach "vm_iprraytraceshadows" rendering property to the mantra node and disable it. Otherwise only ray traced shadows are used for the IPR.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×