Jump to content
Sign in to follow this  
ISUther

Arnold for Houdini 17. Anyone got it to work?

Recommended Posts

Arnold for Houdini 17. Anyone got it to work?
 
I downloaded HtoA 3.2.0 from
 
Installed also license server from here:
 
houdini env file was automatically edited by plugin installation. But i cant get it to work.
In houdini there is no arnold shelf and cant add it as there is no such shelf.

Share this post


Link to post
Share on other sites

What version of HOUDINI 17 do you use?

 

Houdini 17.0.352 this is the version , do you have this ONE ??? 

FX

 

 

Share this post


Link to post
Share on other sites

my Houdini env file looks like this: 
#
# Houdini Environment Settings
#
# The contents of this file are read into the environment
# at startup. They will override any existing entries in
# the environment.
#
# The syntax is one entry per line as follows:
#    VAR = VALUE
#
# Values may be quoted
#    VAR = "VALUE"
#
# Values may be empty
#    VAR =
#

# Example:
#
# HOUDINI_NO_SPLASH = 1
# htoa config start
PATH = "$PATH;C:/Users/ISUther/Documents/Arnold_renderer/htoa-3.2.0_r9e1313b_houdini-${HOUDINI_VERSION}/scripts/bin"
HOUDINI_PATH = "C:/Users/ISUther/Documents/Arnold_renderer/htoa-3.2.0_r9e1313b_houdini-${HOUDINI_VERSION};&"
# htoa config end
HOUDINI_DSO_ERROR = 2
PATH = "C:/ProgramData/Redshift/bin;$PATH"

HOUDINI_PATH = "C:/ProgramData/Redshift/Plugins/Houdini/17.0.352;&"




HOUDINI_NVIDIA_OPTIX_DSO_PATH = C:/Users/ISUther/Documents/houdini17.0\optix

 

Note! i do have redshift also installed, but i wanted to try Arnold for skin shaders as i am trying to pick a rendering engine for houdini.

Arnold itself (that installation) is installed to directory as: 
C:\Users\ISUther\Documents\Arnold_renderer


I have installed Houdini 17.0.352
And arnold for houdini is version 3.2.0-165753147

Share this post


Link to post
Share on other sites

Hi,

here is how mine got setup 

if it may help in some way 

I did change the path the second time again, the first time did not show up for me either.

C:\Users\ISUther\Documents\Arnold_renderer 

To

new installed to:

C:/HTOA17

 

 

#
# Houdini Environment Settings
#
# The contents of this file are read into the environment
# at startup.  They will override any existing entries in
# the environment.
#
# The syntax is one entry per line as follows:
#    VAR = VALUE
#
# Values may be quoted
#    VAR = "VALUE"
#
# Values may be empty
#    VAR = 
#

# Example:
#
# HOUDINI_NO_SPLASH = 1


# htoa config start
PATH = "$PATH;C:/HTOA17/htoa-3.2.0_r9e1313b_houdini-${HOUDINI_VERSION}/scripts/bin"
HOUDINI_PATH = "C:/HTOA17/htoa-3.2.0_r9e1313b_houdini-${HOUDINI_VERSION};&"
# htoa config end

HTOA17.jpg

Edited by mangi

Share this post


Link to post
Share on other sites

I got it working but now have new issue. 

 

Arnold trial renders object as it has lights on it even tho i have 0 lights added

 

Arnold trial renders object as it has lights on it even tho i have 0 lights added
I am first time using Arnold. Should it work this way?
And when i add a light and try to change the intensity nothing happens renders out same way

 

Edited by ISUther

Share this post


Link to post
Share on other sites

With no Arnold Lights 

No Arnold Light.jpg

 

This will come up in the render with no Arnold Lights and No Arnold Shader.

It will pick up mantra default light:

No Arnold Light_No arnold shader.jpg

 

Are you seeing something like this ????

 

Mangic

Edited by mangi

Share this post


Link to post
Share on other sites

You have to put the Arnold Shaders on your Object first:

I think this is what you are seeing

Just my intuition_

 

Arnold shader.jpg

Edited by mangi

Share this post


Link to post
Share on other sites
24 minutes ago, mangi said:

You have to put the Arnold Shaders on your Object first:

I think this is what you are seeing

Just my intuition_

Here is where i try to explain the issue. 

 

Share this post


Link to post
Share on other sites

Hi,

You have to build a Arnold Shader.

Here is how.

Mangic

HTOA17 Arnold shader.mp4

 

 

HTOA:

https://docs.arnoldrenderer.com/display/A5AFHUG/Shaders

 

Also just incase you need to assign the Arnold Render aswell. OK

 

Here is a real Kool intro to Arnold with Houdini,

1:30 starts to build an Arnold Shader

 

Mangic

Arnold output render.jpg

Edited by mangi

Share this post


Link to post
Share on other sites

thnx. 

But where do i get alshaders?
Or i get those only when i buy arnold? (not included in trial?)

Share this post


Link to post
Share on other sites
7 minutes ago, mangi said:

Thnx again. :) 
Also trying to figure out why i get this error.. happens when i start tweaking parameters in Arnold "ropnet1" 

Atm trying to figure out other issue: 
00:00:06 2065MB WARNING | [htoa.node.node] [soho] Parameter not found: radius (ar_radius) 00:00:21 2150MB WARNING | [htoa.node.node] [soho] Parameter not found: radius (ar_radius) 00:00:22 2186MB WARNING | [htoa.node.node] [soho] Parameter not found: radius (ar_radius) 

Share this post


Link to post
Share on other sites

 

Cheers

Mangi

Edited by mangi

Share this post


Link to post
Share on other sites

Thnx!

DO you know good tutoprials for Houdini alshaders. cant connect it directly to OUT:material
 

3.PNG.png

4.png

Share this post


Link to post
Share on other sites

Hi,

Looks like these AISHADERS are not programed for these vesion:

I just set that folder up and I get the same result as you.

So I don´t know if there is any new AISHADERS for these versions.

I am not sure OKAY.

 

I Found these ARNOLD Tutorials this morning. 

 

https://www.youtube.com/channel/UC1KDwEVBlxr4ew7xqLOhu9g

 

 

Edited by mangi

Share this post


Link to post
Share on other sites
15 hours ago, mangi said:

Hi,

Looks like these AISHADERS are not programed for these vesion:

I just set that folder up and I get the same result as you.

So I don´t know if there is any new AISHADERS for these versions.

I am not sure OKAY.

 

I Found these ARNOLD Tutorials this morning. 

 

https://www.youtube.com/channel/UC1KDwEVBlxr4ew7xqLOhu9g

 

 

Hey!

Thank you so much for trying to help. This means a lot to me. 
As when i study myself and no mentor i some times study something and then discover that it is no longer done this way or it does not work any more with this or that is some times frusturating. 
regards AL shaders i got this info> 

https://answers.arnoldrenderer.com/questions/10628/arnold-trial-renders-object-as-it-has-lights-on-it.html?childToView=10693#answer-10693

 

alshaders is not longer being developed.

Also have problem. I do not have AIImage node and i think i am missing some other nodes also.

 

Edited by ISUther

Share this post


Link to post
Share on other sites

Hi Tanel.

Just for the test purpose I did the following:

 

 

htoa aishaders.jpg

PATH.jpg

This way Arnold will find the AIshader.

The thing is they don´t work on this last version of arnold and Houdini 17.

Not really to sure what was the last version ?

 

I am looking around on internet to see okay ... 

But it will be difficult to get those shader if they don´t develope them any more.

Ther mat be some older version...

 

Edited by mangi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×