Jump to content
zinogino

Retime Fluid Mesh

Recommended Posts

Hey wizards,

So I'm pretty stoked on the new retime sop but I'm having trouble getting it to work on meshes.

In the attached image, flipSim_cache is 90frames and in the retime sop I'm trying to extend the length to 175frames.

Problem is, I'm able to slow the animation down but it always end at frame 90 without finishing the original animation.

If I turn the interpolation on, my mesh is all messed up.

Any pointers would be very much appreciated.

Thanks!

retime.png

Share this post


Link to post
Share on other sites

Hi Zinogino, 

What you are trying to do will never work. The fluid mesh is an arbitrary mesh and the point numbers will be in different and in different places every frame, as far as Houdini is concerned it might as well be completely different shapes so there is nothing to interpolate. That is why you have to transfer velocity from points as well.

If you want to retime the simulation you will have to do it before you mesh the fluid.

Hope that helps.

Share this post


Link to post
Share on other sites

Hey there zybrand,

Thanks for pointing out the error on my setup.

However, I'm still experiencing weird issues when trying to retime after the compression cache as if interpolation is checked, it still glitches and it goes away if it's unchecked.
 

Share this post


Link to post
Share on other sites
11 hours ago, zinogino said:

Hey there zybrand,

Thanks for pointing out the error on my setup.

However, I'm still experiencing weird issues when trying to retime after the compression cache as if interpolation is checked, it still glitches and it goes away if it's unchecked.
 


Check this good video.
 


In short,i think solution is:Disable Reseed Particles in Fluid Solver->Retime-> Mesh fluid will be helpful.
 

Edited by Iskander

Share this post


Link to post
Share on other sites

Alright, don't wanna create an extra thread but would appreciate if anyone could point out my error in meshing my fluid sim.

My settings:
Particle separation 0.0035
Particle radius 1.2
Grid scale 2
Min Substep 1
Max Substep 8

Reseeding off
Swirly Kernel

In my particle fluid sourcing, I've played with filtering etc and it's still showing such stepping.
Stepping goes away if I decrease my particle separation to ex: 0.015
Happy to share a strip down scene file.

 

houdini_2018-11-19_17-22-24.png

Share this post


Link to post
Share on other sites


Maybe will be helpful.
Why u just not attached the scene file?
I am not skillful in fluids,but maybe anybody with exp can easy find the solution with scene file.(

 

Share this post


Link to post
Share on other sites

如果您的缓存数据中没有ID 属性,也许您可以尝试选择ID属性并再次缓存它,然后使用timeblend sop,这可能会改变。

Share this post


Link to post
Share on other sites
21 hours ago, Adef said:

如果您的缓存数据中没有ID 属性,也许您可以尝试选择ID属性并再次缓存它,然后使用timeblend sop,这可能会改变。

嗨,已经有ID了。
我已经找到问题在哪了,我的emitter substep不够

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×