Jump to content
logix1390

rbd forces question

Recommended Posts

Hello all,

I am trying to go a little more in depth with the rbd force nodes in houdini. I am working with the magnet force in particular. 

I have a constraint network with random constraints set to a strength of -1 which means it will never break. However, when I use the magnet force on this constraint network it breaks everything and does not respect the strength of -1.

Why is this ? How can I use the magnet force to respect the attributes I set to the constraints?

I will attach my scene file for anyone that wants to take a look.

Thank you

forces_question.hipnc

Share this post


Link to post
Share on other sites

Set the second wrangle to run over primitives instead of points, then it'll work.

Also, in your glue in DOPs, set the strength to 1. It acts as a multiplier to your prim attribute.

Share this post


Link to post
Share on other sites

@FlorianEggers Thank you ! that works.

I noticed there is actually a sop called "glue cluster" that does the exact same that i was doing in the wrangle. It seems to set the attribute correctly but it does not actually work in dops. Is there a way to get this node to work properly ?

forces_question2.hipnc

Share this post


Link to post
Share on other sites

In DOPs in your glue constraint relationship, make sure the Data name matches the constraint_name attribute exactly (case sensitive!).

In your scene, the glue cluster sets the name to uppercase "Glue", the glue constraint relationship has it's data name set to lowercase "glue". Make sure they both match exactly

Edited by FlorianEggers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×