Jump to content
ejr32123

compiled block trouble

Recommended Posts

hey,

I am varying some random instances through the use of a switch node, copy to points, and a foreach loop. Once you start instancing large amounts, the foreach loop starts to get really slow. I can speed this process up by using a compile block. The problem is it stops varying the instances from my switch node and only scatters one of the objects. If you toggle on/off enable compiling, you can see it switch between varying and not varying. I know the problem has to do with my point expression in the switch sop. I tried adding a spare parameter like the documentation suggested, but I must be doing something wrong. Any ideas?

thanks

compile.png

testc.hip

Edited by ejr32123

Share this post


Link to post
Share on other sites

Thanks, I thought there might be another way other than adding all those begin block/compile nodes. I guess that is the way to go!

Share this post


Link to post
Share on other sites
On 12/21/2018 at 6:25 PM, ejr32123 said:

Thanks, I thought there might be another way other than adding all those begin block/compile nodes. I guess that is the way to go!

a more flexible way would be to pack every individual shape piece beforehand, pass as a single geo and then just isolate piece you want per point within foreach

this will give you flexibility of having any number of shapes without having to modify your network

testc_3.hip

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×