Jump to content
art3mis

Vellum cloth - removing stretch

Recommended Posts

Thought this should be self evident and simple.

On the Vellum Cloth Constraints SOP simply crank up the Stiffness value under Stretch.

 

But no matter what values I use there is still huge amounts of stretch as visible in the larger polys near the top of my simulated cloth.

How to remove stretch entirely?

vellum_stretch.png

Edited by art3mis

Share this post


Link to post
Share on other sites

You may need to increase Substeps or at least Constraint iterations on the Vellum Solver to allow constraints to converge otherwise no amount of stiffness will be enough

  • Like 1

Share this post


Link to post
Share on other sites

I've encountered a similar problem. The peak of the cloth gets completely blown out.

Is there any possibilty to get an even stretching?

Maybe a way would be to somehow change the exponen of the pulling force dependent on the rest/current length ratio?

 

Futile solution attempts:

- Changing Stretch Stiffness

- Increasing Subdivisions

 

In the attached video demonstrates the problem.

stretch.mp4

Edited by AlSk

Share this post


Link to post
Share on other sites

As mentioned Increase Substeps and also Contraint iterations.

The defaults are WAY too low.

Stiffness has no effect on the 'stretchiness'

Share this post


Link to post
Share on other sites
19 hours ago, AlSk said:

Is there any possibilty to get an even stretching?

while having enough substeps and constraint iterations is important for cloth to converge, 

in your case you are forcing your cloth to stretch so it can't converge fully to constraint rest lengths, which may cause artifacts you are seeing as every constraint tries as hard as it can, but unlucky points around collisions will always lose as collisions will move them back

you'll need to decrease Stiffness a lot to like 1000 or 10000 to allow the cloth to stretch, then furthermore increase Smoothing steps to get more even stretching

also you can increase collision iterations to get better ratio of interleaved constraint/collision iterations 

 

Share this post


Link to post
Share on other sites

What I actually need is a The Frighteners like effect where a figure stretches and deforms the ground in a 'clothy' manner.

I noticed that the blow out is caused by a too little friction that can't counteract the pulling of the stretch. So the cloth gets stretch infinitely.
Increasing the friction on the other hand leads to conflicts with the constraints. The cloth on the borders of the collision object starts to jitter.
So in the end I got the best result so far with the following settings:

    - Constraint Iterations: 1
    - Static Threshold: 0
    - Dynamic Scale: 5
    - Enable Self: 0
    - Substeps 1 and the rest default

Seems kind of hacky, but more Substeps and Constraint Iterations made it in my case even worse.

Attached before and after.

now_v0011_o0001.mp4

before_v0010_o0001.mp4

Edited by AlSk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×