Jump to content
Sign in to follow this  
parth

VDB rendering in Arnold Maya (temperature problem)

Recommended Posts

I was trying to test render a vdb smoke using Arnold volume in maya. I created vdb file from Houdini. When I render just density for the smoke, it works just fine but when I try to render temperature for the fire this weird thing happens. Does anyone know why this is happening?

Capture.JPG

Share this post


Link to post
Share on other sites

Hi All.

was just messing around abit.

Anway here are a couple of files with the export method from Houdini "HTOA" into Maya "MTOA" using the VDB files.

The lighting is a peace of crap but, I was justing seeing if the Arnold "standard_volume" was working on "parthquestion

 

Quote

when I try to render temperature for the fire this weird thing happens

Can´t really figure out what his scene could be like but, what I tested would work like these files:

Like I said before the lighting really sucks, and excuse my language .

Anyway here they go just incase anyone is really interested on doing this.

I am pretty supprised how easy this method is to work with:

 

Mangic

fireball.hipnc  "Houdini pyro fireball" export files i  VDB format:

fireball_arnold.hipnc "Imports VDB files and applied arnold Volumeshader"

vbd.mb "MAYA scene Importing frame 53 VBD that was exported or ""Write File" from Houdini

fireball.53.vdb "VDB frame 53 used in MAYA scene and applied Arnold VolumeShader"

vbd Maya Htoa.jpg

Edited by mangi

Share this post


Link to post
Share on other sites

Hey Mangi,

Thank you so much for all the research. I have been thing the same thing for rendering. I exported vdb explosion from Houdini and imported in to the Arnold volume and did same thing that you showed. But, it gives me the same result that I showed in earlier post. Then I tried the vdb file from open vdb website and applied the same shader which works just fine as yours. This is vdb file that I exported from houdini Explosion01_057.vdb

Share this post


Link to post
Share on other sites

Hi 

the vdb on the right is your file on the left is the one I did.

Can you put your file  up so I can see how you are exporting it.

Your file comes in just like the render is displaying.

The file is not good , it is not because of the render.

Mangic

Edited by mangi

Share this post


Link to post
Share on other sites

See in the details.

there is another part of the pyros at the same time.

Like if  there where two parts inside the VDB file. 

 

details.png

Edited by mangi

Share this post


Link to post
Share on other sites

Hi Mangi,

Thanks again for checking it out. I am uploading my Houdini file in here. I am using Indie version. 

So, basically what I do is create a sphere>apply pyro explosion to it>Go under pyro import node>add convert vdb node to visualization>the add file node to convert vdb to write files.

pyrovdbtest.hiplc

Share this post


Link to post
Share on other sites

I don't know what wrong I am doing to export vdb. Do you do the same thing to export vdb or you do it differently?

Thanks

Share this post


Link to post
Share on other sites

Hi Parth,

I looked into your scene, and did not find anything unusual.

I noticed in your export the Grids you use, image 1, not sure if it is relevant but in The Arnold Doc´s just has the ones like Image 3

Any way here are the Files.

Just try what I did , make a new scene from scratch. It´s just a simple test scene you have. 

 

After awhile I decided to make a scene from scratch in HOUDINI indie 

and exported the VBD like in this file I am uploading.

loaded the VBD and the render is OK

Hope this can help you , 

mangic

 

kaka.hipnc

kaka.vdb

1.jpg

2.jpg

3.jpg

4.jpg

Edited by mangi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×