Jump to content
art3mis

Interrupted Simulations

Recommended Posts

I often find myself interrupting a long simulation just to ensure everything is working as it should.

But then when I try and finish the simulation  by specifying the frames where I left off, I often find that I am recooking the same frames, starting at frame zero.

For instance I interrupt the simulation at frame 100, then in the Cache or Vellum IO SOP specify the start frame as 101 and end frame as the last frame in my sequence.

Then a Save to Disk shows that I am recooking frames 1 thru 100 instead of starting at frame 101 as specified.

Why, and how do I prevent this from happening?

 

 

 

Share this post


Link to post
Share on other sites
13 hours ago, art3mis said:

I often find myself interrupting a long simulation just to ensure everything is working as it should.

But then when I try and finish the simulation  by specifying the frames where I left off, I often find that I am recooking the same frames, starting at frame zero.

For instance I interrupt the simulation at frame 100, then in the Cache or Vellum IO SOP specify the start frame as 101 and end frame as the last frame in my sequence.

Then a Save to Disk shows that I am recooking frames 1 thru 100 instead of starting at frame 101 as specified.

Why, and how do I prevent this from happening?

 

 

 

 

Did you change Start Frame parameter wherever you simulated: in a Dop Network or a Vellum Solver?

startframe.thumb.jpg.95b819ddb5bcf835a1fd07dd03109388.jpg

Edited by vicvvsh

Share this post


Link to post
Share on other sites

Thanks guys! Need to revisit the documentation on the difference between .bgeo and .sim files.

The VellumIO SOP doesn't seem to have CheckPoint options. Will look at changing my workflow, perhaps with Cache SOP or...

 

No I usually never change the Start Frame on the actual Solver node.

Share this post


Link to post
Share on other sites
10 minutes ago, art3mis said:

No I usually never change the Start Frame on the actual Solver node.

When you simulate from not first frame you should

Share this post


Link to post
Share on other sites

you can try to increase cache memory for your sim

if the dopnet has all frames cached in the memory up until where you stopped it should just continue if you ask to render from there, unless something is invalidating the cache upon hitting the Save To Disk Button

so it may be dangerous as you are always risking that

 

you can also just do your initial cache by hitting Save To Disk In Background, which will do the sim in a separate thread

so in your scene you will be able to read and see how the sim is progressing, if you like it just let it finish or keep checking as the frames are being simmed

if you don't like just kill the background process

Share this post


Link to post
Share on other sites

.sim files are not a thing with the vellum solver sop. You need to use the vellum dops in a dopnet to have access to writing out .sim files.

Edited by Midasssilver

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×