Jump to content
Sign in to follow this  
RyanJP

How To Get Accurate UVs From Vellum Post Process (Extruded & Subd'd)

Recommended Posts

Fairly new to Houdini and I feel like there must be a trick to this- how to get accurate UV's from Vellum's Post Process node for export into an Alembic. I create my UV's at the top of the Vellum chain before sim- let's say it's a grid object. The last step in the Vellum process is obviously the Post Process node where you can subdivide and extrude the object. This screws up the initial UVs as now there is way more geometry. Applying a UV texture after this doesn't work as it recalculates every frame. How can I make this work correctly?

Share this post


Link to post
Share on other sites
1 hour ago, RyanJP said:

This screws up the initial UVs as now there is way more geometry.

how does it change your uvs? do you have an example?

Subdivide and extrude should not change your uvs noticeably

however Spatial Smoothing and Detangle can shift point positions so that any applied texture may seem more disturbed

Share this post


Link to post
Share on other sites
1 hour ago, anim said:

how does it change your uvs? do you have an example?

I do! The first image- the pattern showing up on the extrusion portion itself or the edge. The 2nd image the weird artifacting around the edges where it extrudes-

 

 

Image 1.png

Image 2.png

Share this post


Link to post
Share on other sites

to streak the uvs along side faces of the extrusion you can unlock Vellum Post Process and inside on both polyextrude nodes uncheck Generate Unwrapped Texture Coordinates for Sides

or maybe extract that extrusion portion and wrap into your own cloth thickness asset that you can append after postprocess so that you don't have to have unlocked nodes in the scene

also you can submit RFE to promote this option or make it default

Share this post


Link to post
Share on other sites
On 2/23/2019 at 2:43 PM, anim said:

to streak the uvs along side faces of the extrusion you can unlock Vellum Post Process and inside on both polyextrude nodes uncheck Generate Unwrapped Texture Coordinates for Sides

or maybe extract that extrusion portion and wrap into your own cloth thickness asset that you can append after postprocess so that you don't have to have unlocked nodes in the scene

also you can submit RFE to promote this option or make it default

You know what I actually noticed when I imported the ABC into C4D R20 that there was a polygon selection for each section of the extrude including the side, so that worked out. The 2nd image was just an error in my Normal node (cusp angle was off). Thanks so much for your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×