Jump to content
Sign in to follow this  
whitecanvas

Hard Constraint Unknown Behaviour

Recommended Posts

Hello everyone,

I have been studying Bullet solver and constraints for destructions,and run into some problems with Hard constraints.

As you can see from the attached I have 2 main problems:

1. the Hard Constraints are read by the network since it visualizing them but they stretch all the way in a weird manner. Now i searched a lot and only found this thread which i could relate to https://www.sidefx.com/forum/topic/44390/ . Although it sound like the problem i am having i don't understand what he means by  

      - "if you have deforming rbd where all motion is from deformation then you need to constraint 
         to the actual points and not to the rbd object itself as rbd object is not moving, the link 
         you are seeing is probably just visual line to center of mass"

2. the rbd packed object disappears if i set the "constraint force  mixing" paramter on the hard constraint node

Any help is much much appreciated

Many Thanks
FrancescoHC_Problem.hipncHC

HCPROB.jpg

Share this post


Link to post
Share on other sites
23 hours ago, whitecanvas said:

Hello everyone,

I have been studying Bullet solver and constraints for destructions,and run into some problems with Hard constraints.

As you can see from the attached I have 2 main problems:

1. the Hard Constraints are read by the network since it visualizing them but they stretch all the way in a weird manner. Now i searched a lot and only found this thread which i could relate to https://www.sidefx.com/forum/topic/44390/ . Although it sound like the problem i am having i don't understand what he means by  

      - "if you have deforming rbd where all motion is from deformation then you need to constraint 
         to the actual points and not to the rbd object itself as rbd object is not moving, the link 
         you are seeing is probably just visual line to center of mass"

2. the rbd packed object disappears if i set the "constraint force  mixing" paramter on the hard constraint node

Any help is much much appreciated

Many Thanks
FrancescoHC_Problem.hipncHC

It works if you animate geometry after assemble sop, set Initial Object Type parameter to Create Animated Static Object in RBD Packed Object and set Constraint Force Mixing from 0 to 1 value in Hard Constraint Relationship dop.

HC_Problem_01.hipnc

Share this post


Link to post
Share on other sites

Hi!!

I am new at houdini and im trying to learn some basics in destruction but i have an easy setup and i dont know why is not working.

I would appreciate any help.

I leave the scene here.

Thanks!!

 

hard_constraint.hipnc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×