Jump to content
tagosaku

how to disable displacement in matnet

Recommended Posts

Posted (edited)

Hi, I try to make a enable/disable switch for displacement, instead of cutting node's connections . So far, I tried to connect 'switch node' between collect node and displaceOutputVariables and Parameters. but it does not work. 

Next, I tried' Properties > add Disable displace Shader rendering'. However, it still renders displacement. Thus how should I properly create displacement switch?

 

I am using copy instance after material is assigned with a "share displacement with instances" in properties. That's why disable button possibly won't work correctly...

Edited by tagosaku

Share this post


Link to post
Share on other sites

hi

1 - if you want to use switch in shader, put it in between the displacement VOP and Displace Output Vars. that works.

2 - if you want to use Disable shader rendering property it will work if you add it to your ROP instead of shader. it should also work as an object property i think, but not sure about that.

Share this post


Link to post
Share on other sites

Davpe, thanks for reply.

Your method also does not work for me. I took many tests and it seem like problems are that I use packed instacing(copy node) and shaders are applied on material SOP. These combination breaks displacement switch. 

Share this post


Link to post
Share on other sites
Posted (edited)

it definitely works, you must be doing something wrong. check the gif and the hipfile.

edit: it works when you have material applied on SOP level with Material node as well.

 

disable_displ.gif

disable_displ.hiplc

Edited by davpe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×