Jump to content
Sign in to follow this  
nuki

Can't create New Output on Material VOP Asset

Recommended Posts

As the title says, when I create a new Material VOP asset the 'New Output' option in the Type Properties is greyed out. If I define export variables inside my surface shader code the 'Shader Call Export Variables' VOP will not bind them. Assigning values to eg. Cf directly in the VEX Surface code does nothing.
How could I output eg. a vector from a Material VOP Asset?

Share this post


Link to post
Share on other sites

In fact, I have yet to find a operator definition type that has the 'New Output' option unlocked??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×