Jump to content
Sign in to follow this  
Lukich

Bizzare collision bug

Recommended Posts

I have a simplest particle system - a single particle emmitted from a location should bounce off the grid. The problem is that if the location is higher then 1.4 on the Y axis, the particle simply goes through the grid, which can be any distance away from the particle and origin. If the location is below 1.4, it'll bounce, stick or sing a happy tune depending on a setup, no problem. Did anyone encounter something like this?

Luka

Share this post


Link to post
Share on other sites

I would assume you have animating geometry? First thing is to make sure you have the "Geometry Moves with Time" option turned on. After that, you can start tweaking the "Collision Tolerance" and/or "Bounce Accuracy" settings (slowly increase the numbers).

When all else fails, you can break down the grid into smaller sub-portions in order to improve the sampling. So instead of using a single Collision POP for the whole grid, use several Collision POPs instead on different portions of the grid.

Share this post


Link to post
Share on other sites

OK, I figured it out. It's not a matter of the distance. If the variance on the emitter is set to 0 and so is the Collision Tolerance. If any of them is non-zero, everything works perfectly. :blink:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×