Jump to content
kiryha

Mantra transparency

Recommended Posts

I am using "glass" material for the outer shape of my eye. I am losing lighting and color (left pic is without outer shape) inside the glass object.
Is it should be like this or I need to set up something else (like in Arnold you need to explicitly set object property to handle transparency)?

transparency.jpg.6c30dc58fc0166069ad79cbe4afdaa78.jpg

Share this post


Link to post
Share on other sites

You can turn on fake caustics on the glass material

  • Like 1

Share this post


Link to post
Share on other sites

Better yet, for this type of thing where your outer eye object is solely faking the smooth / wet surface of the eye, turn off all shadow casting and indirect lighting contributions, and you get a little faster rendering bonus

  • Like 1

Share this post


Link to post
Share on other sites

How can I disable all shadow casting and indirect lighting contributions on Geometry level? Or it should be done in the shader (I have no idea how to do it as well)?

Share this post


Link to post
Share on other sites

I have had the exact same problem. 

The best solution I found (although certainly still not quite where I wanted it to be) was to build my own shader instead of using the glass shader preset.

So add a material builder node and inside that add the classic shader core. In the classic shader core, turn down diffuse and reflection completely. Basically you only want that for the refraction (the IOR is in the settings tab, should you need to change it). Then add a PBR Reflect node for your reflection - daisy chain style. And you are good to go. Looking something like the attachment. 

This barebones shader was put together by one of our guys to deal with glass windows that would render with so much noise. So, it can do that too...

glass_shader.PNG

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/8/2019 at 5:04 PM, kiryha said:

How can I disable all shadow casting and indirect lighting contributions on Geometry level? Or it should be done in the shader (I have no idea how to do it as well)?

you can do the same what Fake Caustics does, use Is Shadow Ray VOP node to switch opacity for shadow rays, in case of turning shadows off switch to constant 0

however be careful with Glass materials that don't cast shadows at all, I remember them producing unrealistically bright values within the Glass, I had the best results with fake caustics or combined with real ones

Edited by anim
  • Like 1

Share this post


Link to post
Share on other sites

Couldn't you also just put -shadow in Render Visibility on the geo node?

Share this post


Link to post
Share on other sites

A thing, which I know is not the problem here, but anyway good to mention when working with smaller characters is to check the "Raytracing Bias" in the Rop node. I had a lot of transparency issues with the eyes on a rather smaller character. So maybe make also sure to check that the bias is small enough. 

 

Share this post


Link to post
Share on other sites

i came across exactly the same thing. the outer layer is simply casting an undesired shadow which can be easily removed in shader with isShadow VOP:

 

  • Like 2

Share this post


Link to post
Share on other sites
On 2019-07-10 at 7:55 AM, Skybar said:

Couldn't you also just put -shadow in Render Visibility on the geo node?

Exactly, by far the easiest - but if you don't want to break out the geo, that cool IsShadow method looks ideal ^

Share this post


Link to post
Share on other sites
5 hours ago, kiryha said:

Is there a way to do - shadow on SOP level?

no. you can do it per object or per shader, as mentioned.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×