Jump to content
eldrich

Alembic > group > blast = missing faces when scrubbing time

Recommended Posts

Posted (edited)

Hello, hopefully someone can help.
I have a creature exported from Maya as an Alembic where some of the normals were reversed. 
I’ve blasted out groups of those points and reversed the normals, then merged them back in.

It works fine on frame 1, but as I scrub time the point numbering changes, so the points defined in the group are wrong. Can I make the numbering stick so groups work?

What would a Houdini artist do? I’m primarily a Maya artist, and in Maya the CVs ID doesn’t change. Could it be to do with how I exported the alembic?
I don't have a Maya licence at home so can't easily re-export to check the options.
 

troubleTeeth1.JPG

Edited by eldrich
typo

Share this post


Link to post
Share on other sites

If the point count is changing then on export the selection method was not even. An alembic exported correctly will preserve geometry info from frame to frame.

A method is to do a bounding box from a group sop to a blast node. You can use a delete sop straight up, but there are a lot less procedural ways to animate the size and bounds. You can try for connectivity/assemble too and see if that brings a consistent result if you are looking to remove a whole tooth. There are more options, but it really depends on how inconsistent the topology is and what part you are trying to delete. Generally speaking direct face selection is generally not done as it can often be defined as a destructive method. You can use direct face selection in a few ways, but with consistent topology. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×