Jump to content
kstrod20

Crowd agent transition issue

Recommended Posts

Hello,

I have a question about agent transitions. Right now it seems that agents will not accept a triggered activation if they are currently in a transition state. In my example attached the agents start running at frame 5 and should stop running any frame after 15. They won't stop until after transition 1 is complete. Is there a way to interrupt a transitions state blend to transition to another state without setting state transition duration to 0?

-Kjell

Transition.hip

Share this post


Link to post
Share on other sites

Read the help card on CrowdTrigger, Playback Time is in seconds, not frame. So you have 5 seconds, which is frame #120 (5*24fps).

Share this post


Link to post
Share on other sites

 

Hi Atom,

First thank you for your reply. I know you know quite a bit about crowds!

Weird, I have the units set to frames on the crowd triggers and they seem to be accurate as long as an agent isn't transitioning. Just double checked my attached file using Houdini 16.5.

I find that no matter what trigger i'm using, the second trigger will not activate until the first triggers transition is complete. I attached the same scene but using seconds and a second transition duration as 0 and have the same issue. The agents should run at 1 second (frame 24) and then stop at 1.1 seconds. The real reason I'm doing this is because I find that I can't cause an agent to ragdoll using RBD impact while it's transitioning.

Attached is the scene in seconds and a scene with the RBD example.

Thanks again for your reply!

Collision_RBD.hip

Transition_in_seconds.hip

Share this post


Link to post
Share on other sites

In your Collision RBD file try setting the Transform Group of the duration CrowdTrigger to 'all'. That may solve your ragdoll transition problem.

Share this post


Link to post
Share on other sites

Thanks Atom,

Unfortunately that did not work. It's strange because it looks like it works for a frame and then reverts back to it's previous position all while keeping it's current state.  

-Kjell

Share this post


Link to post
Share on other sites
Posted (edited)

After playing around with the scene, the problem seems to be substeps. Your collider is moving very fast so it is actually passing through the agents, sometimes. The crowdsolver defaults to 5 min and 5 max substeps. Set the crowdsolver min max substeps to 1,1. Jump one level,and set the crowdsim dop network substeps to 5. This will cause all nodes, inside the dop network, to run five times, for every frame. A little slower to sim, but this seems to solve the RBD transition problem.

ragdoll.gif

ap_crowd_ragdoll_Collision_RBD_071519.hiplc

Edited by Atom

Share this post


Link to post
Share on other sites

Hey that did it! Thank you! That one was driving me crazy. I had tried cranking up the substeps on the crowd solver and bullet solver but not in the dop. Thanks again for helping me out!

-Kjell

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×