Jump to content
Sign in to follow this  
jonjonmakemake

Particle Material Assignment Problem - Redshift

Recommended Posts

Hello, 

 

I'm currently pulling to hair out trying to figure this issue out but what I had a problem with is assigning a Redshift material to particles in my scene...

 

So I have set up a particle dust burst based of an Entagma tutorial and now that I have one I need to create some duplicates of that burst. I have simplified the hip file attached but my little animation has three dust bursts obj merged together so that I can then feed them into a popnet with a vortex so they all swirl up together after they have done their little burst thing. I got that all working so far but when I go to attached RS materials to each separate burst I can't do it. I can assign a material at the obj level and it works fine, the colour changes for all of them *hurray!* but I need each dust burst within the obj geo node to have a different colour. Soooo I dive inside add a material node but the particles render white and seemingly just fail to see the material node. I have tried adding group assignments to the tree above the mat node and then using them to drive the mat assignment but it doesn't work. I've tried attribute create and attribute promote and they don't seem to help.

So it seems that I can only assign a material at the top obj level and not within a geo node, but that has to be a bug right ? or what am i doing wrong? 

I hope I am explaining that alright and I appreciate the help in advance ! 

 

 

Dust_Material_Problem_v001.hip

Share this post


Link to post
Share on other sites

Not a bug is just how RS works if you are using the particle tech. So you best bet split them out in 3 different geos and obj merge each individual grp particle that you want to look different.

Share this post


Link to post
Share on other sites
On 31/07/2019 at 1:03 AM, Sepu said:

Not a bug is just how RS works if you are using the particle tech. So you best bet split them out in 3 different geos and obj merge each individual grp particle that you want to look different.

Hey Sepu thanks for getting back to me, I had been doing that and I tried it again with no luck. Also now I have a problem where within a geo node, if I  attached a material node  it freezes up my computer and the scene view looks like the particles are node giants black square sprites or something. Could you see if you can replicate that problem? I've attached a new hip file. 

 

also here are my computers specs just in case. 

 

Processor - Intel (R) Xeon (R) CPU E5-2690 v3 @2.60GHZ - 2.60 GHz (2 processors)

Ram - 64GB

64bit operating system x64-based processor

Windows 10

Graphics Card - NVIDIA Geforce RTX 2080 Ti

Houdini Version - 17.5.229

 

 

 

 

 

 

Dust_Material_Problem_v002.hip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×