Jump to content

Recommended Posts

Hi there everyone.

I am having a really strange issue with my river scene when I render it out.
The reflective of the water seems to turn on and off randomly.
I then did some further testing and found it to be the interior Volume giving me issues but this only happens in the center section of my River, the Top and bottom are not affected by this problem.

Below I have two Images to show the result of the Volume issue which is consistante on these two Frames even if I re-cache the Sim

Frame 350, the Volume in the center is really Thin.
Volume_Frame_350.thumb.png.2f2651450a77e158ee70b609b92b6161.png

Frame 357, the volume is much Thicker in the center.
Volume_Frame_357.thumb.png.63dcd798b4da8596c3c3fd2f455932a0.png

Please check out the Link HERE for a low quality render with a few frames on Vimeo.
Password : JodysFX

I feel like there is a setting I am not turning on or a value thats two low. It might be in the Surfacing node but I am not sure, I will continue to test.

Any help is greatly appreciated.

Share this post


Link to post
Share on other sites

Have you been able to replicate this error with a small and simpler scene?

Share this post


Link to post
Share on other sites

Hay Guys thank you for your Replies.

@kleer001 I have not tested with a smaller Scene just yet. I was going to test with a Flip tanks but I wanted to test a lower res sim first without Running it through the Fluid compression. This actually worked and I am running a High res cache now to see if it could have been the fluid compression node.

@jonidunno I am rendering locally.

Share this post


Link to post
Share on other sites

My intuition tells me there's a problem with the geometry, but that's difficult to diagnose. I think your water might be creating holes randomly, the top and the bottom of the water meeting and making bubbles which confuses the volume renderer, it doesn't know what's inside or outside. A fix? Deeper water. Or create your volume manually, but that leads to rough rasterized edges. How to test? Make a much smaller demo scene with similar settings and relationships between the parts.

  • Like 1

Share this post


Link to post
Share on other sites

Hi there @kleer001 so yea I had the same thoughts that it was the geo. So I went through the Surface node trying to see if there was a setting I didnt turn on or miss typed a value with No luck.

The Non Fluid Compressed Cache finished today, so I did a test render and the volume was perfect, I then ran the cache through the Fluid Compress and the volume issue came back.

I seem to think that the Fluid Compression is removing points that are needed as I am doing a Narrow band so It shouldn't have to remove much.
The sim is around 36 Million Particles. After the Fluid compression, it goes down to 19 Million.

Any Thoughts Kleer001 ?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×