Jump to content
jamesearnest244

Can't Get Rid of Particle Stepping

Recommended Posts

Hi,

I'm trying to get rid of particle stepping issues caused by a fast moving source. I've tried many different solutions but none have worked. Basically, I have a Debris Source SOP, and the points from there are fed into a POP Network. The stepping is due to the fast movement of the source particles from the Debris Source.

Things I've tried:

1) Increasing substepping on the POP Network - doesn't seem to do much, and going too high makes the sim explode.
2) Adding a Trail SOP after the Debris Source - doesn't produce a good result, because the trails are created along a rigid straight trajectory between the interpolated positions.
3) Timeshift the Debris Source one frame back, use a Point Wrangle to interpolate the modified points and the original points with a lerp function. This creates a jittery motion path because the interpolation bias between the positions isn't constant (and if it were constant, this would essentially be like a trail SOP).
4) In the POP Network, switch on Jitter Birth Time and Interpolate Source. Helps somewhat, but still leaves visible gaps.
5) Point Jitter - really just fuzzes everything up.

Really, I don't understand why substepping doesn't do the trick, isn't this exactly what it's for? There has to be a solution to this, it seems this would be a very common problem in FX...

Thanks for any help!

Edited by jamesearnest244

Share this post


Link to post
Share on other sites

This my be stupid but just an idea from when i read you post. is the moving source cached with enough substeps?

Share this post


Link to post
Share on other sites

it's always a good idea to set the frame rate of the timeline to something low and check what is going on in those subframes.

Share this post


Link to post
Share on other sites
21 hours ago, ekan de said:

This my be stupid but just an idea from when i read you post. is the moving source cached with enough substeps?

That was it!

Interestingly, if I also cache the Debris Source SOP before it's fed into the POP Network (also caching the same number of substeps), the POP Network doesn't read the substeps and I get gaps again. But if I don't cache it, it works perfect! I guess something about caching the Debris Source SOP messes things up, but this isn't crucial.

Thanks so much for your help!

Share this post


Link to post
Share on other sites

Whenever you're running into issues like this, it helps to throw down a Timeshift SOP, uncheck "integer frames", and break the connection in the "Frame" parameter. Use the ladder to scrub forward/back in like 0.1 increments. If the source moves smoothly no matter how granular the unit which which you're scrubbing is, you should be good.

When you're simulating and you're caching to RAM, houdini has everything it needs to access subframe data (which is why you're seeing correct results when you don't cache your source). When you cache to disk, by default it saves on whole frames. When the cache is read back in, you only have access to what was written to disk, so when you're running a particle sim with say 5 substeps, and houdini looks up frame 1001.2 of the incoming source, there won't be anything there. The Time Blend SOP will interpolate between frames for you. In most cases, it is necessary to have an i@id attribute on your points, since especially for particle simulations the point count may not be stable, and the Time Blend SOP won't work correctly. 

Unless there is significant motion in between whole frames, it's not necessarily required to write substeps to disk. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×