Jump to content
Sign in to follow this  
Marcocheng

Boolean shatter troubleshoot - failed

Recommended Posts

Hello folks!

image.png.f13fc6643021e1f4195fcfa258c3627f.pngimage.png.eacfa291e092e6e3e92925dcb7801504.png

I have a pre-fractured piece which is a watertight mesh (from the previous simulation) and cutting plate (grid with noise) and planned to do a secondary fracture. Direct boolean fracture is failed to cut them apart. Meanwhile, when I VDB remesh the pieces before boolean fracture it works like a charm. Here's the network.

image.png.9236f171f8077023e9989332150ce719.png

Fracture result: 

image.png.e5923da87aa93ab5fabbdd7b9aff35af.png

LEFT(VDB remesh before shatter): The cutting is working as expected.

image.png.1c826a02677f36ee58ee552a385fd041.png

Mid(Regular remesher before shatter): The cutting is not working at all. 

image.png.ad5728d5ff94273c18d1dd6f0297827c.png

Right (Original pieces): The cutting is not working at all. 

 

I tended to use the original pieces as I want to have the original UVs. But the fracture is failed. Any tips to prepare pieces to fit into boolean shatter tools? What's actually causing the problem here? Thanks!

 

File for troubleshooting:Booleanshatter_TroubleShoot.hip

Share this post


Link to post
Share on other sites

Hi,

the problem is that this original piece is not watertight geometry, look carefully at it. Find the causes of this in first fracturing and fix them.

Share this post


Link to post
Share on other sites

As vicvvsh pointed out, your geometry probably isnt closed. I had a similar issue white doing a shatter on an impoted 3d scan. For me, a combination of Clean and Fuse SOPs fixed it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×