Jump to content
sant0s81

Flip Fluids on 50 fps totaly messed up

Recommended Posts

Hello,

first: sry for asking so high frequenced on Flip Fluids!

I have a very strange problem.
My Flip Fluid simulation on 24 fps worked perfectly - with the right scaling and settings I got beautifull results.

Now I got a scene with an animation, that has 50fps (also in the scene file).

I actually did the same thing than in the other simulation. Scaling and settings are quite similar.

But now my simulation explodes.

What I did was playing around with the "Scale Time".
The fluid is not exploding anymore, but it also gives me very unrealistic results, specially the whitewater

Share this post


Link to post
Share on other sites

Hey, try to retime it.

Reset the time scale parameter, check "add ID attribute" and put down a retime node, and for points check if the "use ID attribute" is set to id. Then use the fit range and fit your simulation to what frame range you want. You may use cubic interpolation to get smoother results.

 

Cheers,

Share this post


Link to post
Share on other sites

Hey @DonRomano

thx for your reply.

I dont really understand that.

The 50fps are also in the Global Settings, Means, everything in the scene is now 50fps.
Actually its the same scene than before more or less, but we had to change everything to 50FPS.
The Fluid Setup is also new, but with the same settings than before.

50fps.jpg.92d4717be950495c4cab976eb0a743ad.jpg

 

So what exactly do I have to retime?

Thanks again :)

Edited by sant0s81

Share this post


Link to post
Share on other sites

are simulations when the scene is set to 50FPS a generell problem? Or should that make no difference?

Share this post


Link to post
Share on other sites

Okayy I didn't understood that. What you can try is to set the time scale at 0,48. Your simulation should behave as it was simulated with 24fps.

 

Cheers,

  • Like 1

Share this post


Link to post
Share on other sites

hey,

that seems to do the trick - I am just doing a flipbook preview, but alreday looks way better!

thx :)

Edited by sant0s81

Share this post


Link to post
Share on other sites

hmm... I just dont understand it.

Everything worked so perfectly in the other scene with 25FPS.

Now, in the new scene thats actually the same thing but with 50FPS, everything looks totaly different and ugly.

The whitewatter kinda bounces on the surface, it exapnds very strange, is to quick etc.

It always looks promosing first and when I start to simulate, suddenly in motion it looks realy ugly.

Anyone has an idea, what I could do wrong here?

watertest.mp4

Share this post


Link to post
Share on other sites

Did you changed the time scale on the ww sim as well ? Try to increase the substeps, it may help. Like 6-8 on the flip sim and maybre 12-14 on the whitewater sim.

Can you also share the file ? It could be simpler if we can have a look at it rather than just wondering around what's going on..

 

 

Cheeers,

Share this post


Link to post
Share on other sites

Hey,

I'll ask if I may share the scene.

And yes, I changed the time scale on ww as well.

I say something tomorrow morning.

Thx! :)

Share this post


Link to post
Share on other sites

Hey @DonRomano

sry for not saying anything yesterday.

I actually found out that I had to use a convert.
I did not see, that the model the company send me in that scene, was not made in Houdini.
So there where lots of collision problems.

 

With convert and changing the scale time, the water looks finaly great.

But Maybe you can give me a hint on the whitewater:

The water itself is okay so far.
Now I wanna get whitewater behind the fin, like a tail.
In the following link at 00:22:

https://www.gettyimages.pt/detail/vídeo/shark-swimming-under-water-surface-vídeos-de-arquivo/9010-107

I get some whitewater, but only at the front or somehow quite spreaded left and right from my fin.

Whats the right parameters to change that I get a nice whitewater "tail" behind the fins?

Thx again! :)
 

Share this post


Link to post
Share on other sites

Hey,

just read, that I just have to copy the collision setup (the fish) I am using in the Water DopNetwork simply has to be copied into the Whitewater DopNetwork, too.

Now I get these tail I want - just playing around with some settings, but seems like thats what I want :)

  • Thanks 1

Share this post


Link to post
Share on other sites
On ‎30‎/‎11‎/‎2019 at 2:31 PM, sant0s81 said:

Hey,

just read, that I just have to copy the collision setup (the fish) I am using in the Water DopNetwork simply has to be copied into the Whitewater DopNetwork, too.

Now I get these tail I want - just playing around with some settings, but seems like thats what I want :)

Hey, you can also set a custom emitter to emit more where you want, instead of using the classic ww emitter. Nice to see you making your way through !

 

Cheers,

  • Like 1

Share this post


Link to post
Share on other sites

Hey,

I try that tomorrow, probably I have to ask again for the custom emitter.

Just rendering the stuff and finaly really happy with the result.
When I got something to show, Ill post it here.

Thx so far again! :)

Best,
sant0s

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×