Jump to content
art3mis

Puzzling FLIP behaviour with reduced Particle Separation

Recommended Posts

AFAIK the ONLY difference in the 2 attached simulations is that in the 'failed' one I have simply reduced my particle Separation from .05 to .025.

 

In each case the resolution of my collision VDBs is directly tied to this resolution.

 

WTF is happening? What should I try to fix this? I need the increased resolution. Pulling my hair out.

Launchv11_025ps.mp4

Launchv8_05ps.mp4

Edited by art3mis

Share this post


Link to post
Share on other sites

You can decouple collision separation from particle separation. Run your collision resolution at a fixed value and your particle separation at another.

Share this post


Link to post
Share on other sites

Thanks. Still gaps in my full understanding of FLIP but wouldn't decoupling in this way mean that your collision resolution would be 'coarser' than the particle separation and make the issue worse?

Just to clarify

I've created a custom Voxel Size parameter on my Flip Object which is a product of Particle Separation * Grid Scale

It is this custom Voxel Size parameter I am linking to on my Collision Source SOP>Volume>Voxel Size

The problem seems to happen when I increase my resolution (reduce particle separation and hence voxel size).

Share this post


Link to post
Share on other sites

I would use it the other way around. I would make the collision surface have a lower particle separation and raise the fluid particle separation. It's har to say without seeing the HIP.

Share this post


Link to post
Share on other sites

Thanks. Will try enabling Collision Separation override and using ch("particlesep")*.5 as a start.

 

Share this post


Link to post
Share on other sites

Voxels aren't linear. Half of your particle separation might cause 100x increase in collision resolution. Your simulation time may go up.

Share this post


Link to post
Share on other sites

So used Collision separation override but still have issue.
Through trial and error though I think I am getting closer to figuring out why.

In 2 tests with the exact same settings, the only thing I changed was the Collision Separation override on my FLIP Object.

When it was set to .5 * Particle Separation the simulation fails at around frame 100.(the particles rapidly drain away)

When it was set to .25 * Particle Separation the simulation fails on or around frame 40.


I checked and OpenCL is NOT enabled on my Solver.

The issue seems to go away when I have a coarse Particle Separation of .05 or more.
What else could be causing this?

Is this possibly memory related??

 

FLIP_Object_CollisionSep.png

Launchv12__FLIP_Failure025ps.mp4

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×