Jump to content
CinnamonMetal

Particles not emitting along vector attribute ?

Recommended Posts

I've created a vector attribute and applied it to normals, but how do I get particle to inherit the vector attribute and flow along this vector; I've inherited the attribute in a POPNet but the particles are not emitting along the vector ?

 

Share this post


Link to post
Share on other sites
Posted (edited)

too hard to guess what your setup is...so here goes nothing...you can adjust the 'target' if you like. Very basic tho so don't laugh.

vu_emit_direction.hiplc

Edited by Noobini

Share this post


Link to post
Share on other sites

ok I'll assume some of you may have laughed...so here's a more sophisticated version. Previously, all particles shoot in a parallel direction since the direction is simply from world origin pointing towards target.

Now, each 'gun' will aim independently at the target and shoot, it does take the position of the individual gun into account.

direction_pp.jpg

vu_emit_direction_pp.hiplc

Share this post


Link to post
Share on other sites

The particles are not inheriting the point vector, instead they are emitting from the point of the vector, which is just the points on the geometry.  Rather then the particles emitting along the point vector ?

particlesflow.png

Share this post


Link to post
Share on other sites

I spent time creating sample files for you and you continue to talk in riddles instead of uploading your file..goodluck man.

  • Like 1

Share this post


Link to post
Share on other sites

You need to define your velocity. If you add the following line to your wrangle it will work:

 

v@v = @N;

You will also need to reset the Inherit attributes parameter back to "*"

Share this post


Link to post
Share on other sites

@Sean-R Thanks, but how do I get the particles to continuously flow around the torus; currently once the velocity has done a full rotation the particles shoot in opposite direction ?

Share this post


Link to post
Share on other sites

To have them flowing around the torus you'd be better off using 'advect from volume'. This way your particle's velocities are constantly being updated, rather than just inherited at the start like in your previous setup.

image.thumb.png.815d412b6a1fe492ab5b6dc3e5e91ba3.png

particles_advect_by_volume.hipnc

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×